Airport Extreme And Azureus Nat Error

mavgo

Registered
Imac G4 connected to Airport Extreme via Ethernet to a Motorola surfboard SB5120.

Cannot fix the NAT error issue have tried the following independently

1: Mapping port TCP Port number 6881 in system pref/firewall with no change
2: Unchecking Distribute IP addresses in Airport Admin Utility/network which will cause a full loss of connection
3: Added port 6881 into Airport Admin Utility/port mapping

I can log into the motorola surfboad via ip address but have no options to do anything beyond resetting it

Any thoughts, thanks

 

mavgo

Registered
no- still not found a solution- even bought an ethernet between mac and airport to try different configs without luck - only way I can get all to be ok is to go stright to the mac via ethernet bypassing the airport - anyone else got a solution??
 

Mikuro

Crotchety UI Nitpicker
I recommend skipping the whole port-forwarding process entirely and instead relying on UPnP (Universal Plug 'n' Play). This will let Azureus temporarily open whatever ports it needs whenever it needs them.

To enable this, go to the Azureus preferences, and select Plugins > UPnP. Check "Enable UPnP" and "Release mappings on closedown". The defaults for the rest of the settings should be fine.

Then select Plugins > UPnP > NAT-PMP. Enable that as well. As Azureus will tell you, you'll also need to enable this in your Airport configuration. I'm not sure exactly where to do this since I'm using a Linksys router, not Airport.

This will only help with Azureus. If you want to use another client, you'll probably need to fuss around with forwarding ports. In that case, I can suggest is using a port besides 6881. Something like 55000-55020 should work nicely (that's what I do). 6881, while the default, is actually not recommended (see the Azureus Wiki for more info).
 

stewblew

Registered
I was looking for the answer to this problem myself, and came across this thread. I managed to get this working, so I thought i'd post my $.02

Follow Mikuro's directions here:
To enable this, go to the Azureus preferences, and select Plugins > UPnP. Check "Enable UPnP" and "Release mappings on closedown". The defaults for the rest of the settings should be fine.

Then select Plugins > UPnP > NAT-PMP. Enable that as well. As Azureus will tell you, you'll also need to enable this in your Airport configuration. I'm not sure exactly where to do this since I'm using a Linksys router, not Airport.
Then, under the Airport tab choose "Base Station Options" and put a check in the box by "Enable NAT Port Mapping Protocol"

And that's it, enjoy...
 

s0krass0r

Registered
well I am pretty disappointed with the airport extreme so far, the admin utillity is pretty strange.... it won't let me use static ips for instance, always says that for internet over pppoe DHCP HAS to be enabled... how ridiculous is that? without static ips how am I supposed to forward ports!?!?! when I tell it to assign only a range of ips, I can't use the port forwarding, it's grayed out, ask me why... and then I tried what you described above for azureus and it simply won't work, when I test the network settings it always says NAT-Error Connection Refused....and the Tracker Info says Connection Error - socket exemption bla bla.....and of course, it doesn't download anything.... anyone any suggestions?! I would really appreciate any help....
thx
 

stewblew

Registered
are you on a mac or pc? i'm guessing mac, if so...

I haven't figured out a way to use static IPs with the router, but on each individual node you can use a static IP. If you only stay on one wireless network, you can use a setting in System Preferences>Network>Airport>TCP/IP and confingure IPV4 to use DHCP with a manual address.

If you travel between wireless networks, you'll have to manually change your IP address for each network you join.
 

s0krass0r

Registered
well thx for the reply first.
yes I am on a mac, but I have numerous problems:
I have set my iMacs Ip to a static ip, that wasn't the problem, the problem is, that azureus still doesn't accept the forwarded ports!
and also I am not able to access my windows file server which is on the network, but my brother, who uses a windows machiene can. Accessing it wasn't a problem at all with my old router.....any suggessions?
Everything else works flawlessly, even the printer I connected to the airport works....
 

stewblew

Registered
Do you have firewall turned on in system preferences? turn it off, if you do. Are you using "connect to server" from finder to connect to your file server? You'll have to use (assuming it is an smb share) SMB://addressofserver/foldername. If you want to set up a good file server, I would set up a dedicated box using FreeNAS. If you have to be able to use the box, you can download the FreeNAS Virtual Appliance and use it with the VMWare Virtual Server (free).
 

s0krass0r

Registered
well firewall is off, also I used to use the finder in order to connect to my network shares, works flawlessly without the airport but with it... well....
it's a windows xp machine with file sharing on, nothing else ;)
the command smb:// worked, I now have control over my shares but not as I used to...when I click on network in the finder it won't display the shares... but anyway that's at least sort of a solution ;)

which leaves the azureus problem....

so what's next? ;)
 

s0krass0r

Registered
45294 I have tried all different sorts of ports though..., I tried using Transmission, another bittorrent client, which uses port 9090, that works somehow...
when I check out my ports using
https://www.grc.com/x/portprobe=9090 it tells me that the port is in "stealth" mode when having dynamic ip, when I use a static ip it tells me that the port is "open" , transmission works nevertheless with good speed in stealth mode, don't ask me why, and also, when using a static ip, I don't see my network shares (I can connect to them manually though, thx to your help) but when I change the ip back to dhcp assigned, I can see my network shares again... so right now it's either Network and port "stealthed" or open port and no network, anyway, azureus won't work with both configs.. any thoughts?
 

s0krass0r

Registered
now something strange happened, without changing anything I can access the Network again, so far so good.
So right now, I have a static ip, Network works, basically everything works, EXCEPT Azureus... UPnP tells me that it establishes a connection but still azureus tells me socket exception bla bla bla
Shields up also reports that port 9090 is running in stealth mode.
 

ickysticky74

Registered
Well I got it to work but everyday that my computer sits idle I loose my connection and have to restart my computer for it to find my airport.
 
Top