Airport Extreme And Dsl 300t


I have a ibook G4 and am trying to set up a wireless network with a base station and a DLINK 300t modem. I have followed all the instructions and still cannot get it to work. The modem works fine plugged directly into the computer ethernet.

Please advise
I'm betting you have an Airport Expess Basestation with the 6.2 firmware. Yes? If so then downgrade the firmware to 6.1.1. This should resolve your issue. Other users of the 300T in conjunction with an Airport Expess Basestation have also had this problem. Hopefully it will be resolved with a future update of the firmware (I have heard that 6.2 has a number of other issues as well). For now just stick with 6.1.1. You can get it from Apple's website here:
Tried a lot of combinations, and finally found the right solution, I think.
First dlink and airport wanted to be both dhcp and conflicts were welcome.
Then I deactivated the one of dlink, given the airport, but when distributing Ip(dhcp&nat) it wasn't possible with static ip's so other option range: But deconnections found place and I still don't understand why. Then tried to dlink dhcp and airport not. But the airport cannot act as a bridge, he WANTS an Ip, so again sometimes internet, sometimes not. meanwhile, the computers had a manual adress using dhcp. then tried dlink to give a range from .1.1 to .1.2 and airport .1.3 to .1.200 worked fine for half a day(DHCP only). Tried last with DHCP&NAT but the airport takes ip and conflict with modem.

Last one I tried, and I had to do it first. The dsl act as a bridge and the airport enters login information to the modem to connect and dhcp/nat. for the moment, It works fine for a week already, but still waiting...
And their, the dsl acts as a real bridge, it asks no ip, nothing, so that was the best solution.

Hope it helped

If it can help my belgian friends, its for the full adsl connection