Airport Extreme And Linksys Wrt54g Router


I just bought my 12" PowerBook (with Airport Extreme wireless card, using "Tiger" OS X) about a week ago. Ever since I brought it home, I have not been able to access the Internet at all. At home, I have a cable line connected to a Linksys WRT54G router, to which one desktop computer (PC) is connected to by wire. My PB (as well as my previous laptop) are the only wireless computers on the network.

At first, I thought that maybe something was wrong with either the router, the computer, or our ISP (AOL). After calling all three (who blamed each other), I got nowhere, although the Linksys tech support gave me extra DNS server numbers - which did nothing but aggravate the process.

After doing more research, I found that many people have had the same problem with accessing the Internet on the WRT54G router. I have heard many ways to try and fix the process and have tried some, but have not been able to do it correctly (I still cannot access the Internet or sign on to AOL).

Here are the settings on the router and the Airport Extreme wireless card as of right now:

Linksys WRT54G router:
Connection type: DHCP (Automatic Config.) - *Note: I have heard that AOL uses PPPoE for this setting instead, but upon using this setting, the PC desktop computer that is wired to the router would not sign on to AOL.
Wireless - network mode - mixed
all default
security - WPA Pre-Shared Key, TKIP
MAC filter enabled (have entered Airport MAC ID)
UPnP - enabled (heard this worked, too, but don't know exactly what it does)

Airport Extreme wireless card:
- is connected to our home network, with the WPA key enabled
- AOL for Mac OS X says that to enable this connection to work, a TCP/IP connection must be established and then modified to include the cable modem. however, upon signing on, AOL cannot seem to recoginze or connect to the TCP/IP connection.

If anyone can shed some light as to how this should work, and what I need to change, it would be appreciated.
I would try to set up the network settings (in system preferences, tcp/ip tab) on the mac manually, ensure that you have entered the router address and choose an ip number that is in the range of ip addresses your lan has assigned by dhcp.
The router should sign on to aol for you, if it works correctly on the pc, then most likely the issue is on the mac.
try to make an ethernet (wired) connection, if this works then it is most likely a security settings issue. Ethernet (wired) connections are usually security free, for home networks.
Have you tried to use the wireless lan without any security enabled?
If the wireless works without security, then add the security measures, one by one, to isolate your problem.
hope this helps.