Airport Extreme Compatible Router to Extend Ethernet Connections



I have the following:

2 x macs connected via Wep Wireless to the Airport Extreme
1 x PC laptop connected via Wep Wireless to the Airport Extreme
1 x PC laptop connected via Ethernet

AE connected to a cable modem.

Now my problem is this. I run a website that streams a lot of video from it (no not that kind of website, its a training site). Now before when I had a Ethernet network it would be very fast (I have a 4mb connection to the net). Now running via AE my streaming is pathetic. Now the networking is fine and I can share system resouces better with the AE. However, I want to connect the main workhorse back via Ethernet on not via Wireless.

Now one of the laptop (Dell XPS 2) has Wifi but it keeps getting booted of the connection. It will stay online for about 5 minutes and then disconnect. I can then try and reconnect, it will connect but state that no connection in the wifi connections. It's a pain and would be great if I could get that to work via wireless, I could then connect the PM g5 2.7 to the Ethernet on the Airport.

Failing fixing that DELL XPS 2 laptop, I will need to get a network ethernet hub that would connect to the AE, or the AE to connect to the hub which ever is better.

So any ideas on how to fix the Dell first of all. It has all the latest updates, have tried turning off the firewall and everything else. The AE connection is 128bit Wep, but have tried with that off to public access and this doesn't work. The dell connected for a while and then just doens't bother, it can find the network, but simply can't connect to it. Even when the signal is super strong.
It works fine on Ethernet though connected to the AE.

If that doesn't work. then what is the best way of connecting my G5 via Ethernet to the AE also?

Any help appreciated!



I had a similar problem which I solved in the following manner:
1) instead of a hub or switch I used a old Linksys router (not wired, but I doubt it matters) with the following administration:
a) turn off DHCP
b) change router IP range to match airport extreme
2) restarted computers