Airport & HP LaserJet 5MP (AppleTalk)

Xenolith

Registered
OK... here are the pieces of the puzzle:

iBook 600 (w/Airport card)
Airport Base Station
Ethernet Routher/Hub
HP LaserJet 5MP (w/AppleTalk and Serial)
Farallon AppleTalk to Ethernet bridge

Both the Airport and the printer (via the AppleTalk to Ethernet bridge) are plugged into the Router/Hub. The only way I know to be able to see the printer from my iBook is to turn the AppleTalk bridge option in the Airport administration tool, but when I do I get a warning about possible connectivity issues that could arise because of this. Is there another way for me to do this?

PS: If I can solve this problem, I'll then see if my issue of Earthlink's SMTP server not allowing me to send emails from the Mail application unless I first check my email with Entourage (via the Classic environment) is fixed... otherwise I'll be making another post. :(
 

twyg

Back to Mac Baby!
I've had the same problem with a computer and printer here. Same setup except it's a linksys router instead of airport, and it's a 6MP instead of a 5...

I'm just looking into a new printer. It's time for an upgrade anyhow.

It seems that the connection gets upset in the ethernet --> serial/localtalk conversion. I've talked to Farallon and got no answer... Not so good on their follow-up apparently.

If someone has a better idea than a new printer it'll help me too. I work for a non-profit that would rather save than spend... ;)
 

mcasteel

Registered
Originally posted by Xenolith
Both the Airport and the printer (via the AppleTalk to Ethernet bridge) are plugged into the Router/Hub. The only way I know to be able to see the printer from my iBook is to turn the AppleTalk bridge option in the Airport administration tool, but when I do I get a warning about possible connectivity issues that could arise because of this. Is there another way for me to do this?
I don't know of another way--you didn't say what happened when you enabled bridging. If you read Apple's document on "Designing Airport Networks" (downloadable from Apple's Support web site), it only says that, in order to communicate with AppleTalk between AirPort and Ethernet, you have to enable bridging. So, maybe that's what you're supposed to do. If you do have problems, post them and perhaps somebody will have the solution.

You mention you have a "router/hub"--if your hub is really your Internet router, it's probably already doing NAT and will serve DHCP to your entire network, including wireless nodes. To do this, in Airport Setup you would uncheck "Distribute IP addresses" entirely, which automatically puts a checkmark in the Bridging option, and Appletalk should work fine (as well as TCP/IP).

I note that Airport Setup lets you enable bridging even while using DHCP and NAT--not sure how they make it work, but if you do have any problems with "Distribute IP addresses" enabled, you may only need to manually configure TCP/IP on your wireless computer(s). See the Designing Airport doc for settings (the ones they give for Ethernet computers to use NAT).
 
Top