Airport Looking for PPPoE Host...



I've had years of good luck with my mac(s) and the internet. Been using an airport extreme base station as my home hub for three imacs and an ibook for a year or two now, and use the ABS to dial-up my ISP and share the connection among my imacs. All that works swell.

My ISP started bringing wireless "hotspots" to our neighborhood (for free) and I figured out how to connect from my desktop 17" G4 1.25GHz imac airport via PPPoE directly to the ISP (not using the ABS as a bridge). I also was able to do this from my ibook (G4 1.25GHz). This worked great for several months -- although the ISP's wireless signal had it's ups and downs during the day.

Late this summer I started having increasing problems keeping the airport PPPoE connection up. I think I went around and upgraded all my desktop imac system files I could think of, but I now continuously get the "Looking for PPPoE Host..." whenever I try to connect wirelessly to the ISP's internet.

Internet Connect tells me my airport card is "connected" to the wireless ISP network, but it has no IP assigned. I looked through the system logs and find that the one recurring message is that when the PPPoE tries to link up with the server concentrator, it says:

"myhostname-Computer kernel [0]: PPPoE inputdata: unexpected control packet on unit = 1"

it keeps repeating this until I switch to my other Net Pref Location and use my ABS to dial the ISP through the regular phone line. I've changed the MTU for en[0] and en[1] to 1490... and made inquiries to my ISP (they've not gotten back to me yet). Since the wireless thing worked so well for several months, then quit, I figure I did something locally to screw up a good thing. I tried to configure the ABS as a bridge to provide the ISP wireless connection ... but that went right over my head and I reset all settings and went back to dial up.

Any suggestions on where to look next? What to do? What questions to ask of the ISP?