AirPort Signal, But Nothing Else



My desktop is an AGP Graphics Pro, 550Mhz single processor with basic AirPort card installed. This baby is my 'classic' and still works fine, currently running Panther on it.

I use the AirPort card to broadcast and effectively I make my desktop my base station. Unfortunately, this means the AirPort Admin Utility is useless because it doesn't recognize my card--it seems only to work for external Base Stations.

For a long time, my PowerBook (I have a three-year-old Titanium with, again, AirPort card installed) worked fine on my home network from the desktop. I got signal every time, and could surf, fileshare, and chat via the Powerbook using the desktop's shared network connection.

Recently, a roommate got a new G4 iBook and wanted to be on our wireless network. We got her plugged in and boom, there was the home network name right there under the AirPort taskbar symbol, we clicked on, and she was surfing the Internet, no problem. Her system is running Tiger (of course).'s the problem.

When we try to use any chat program (iChat, Adium), it never connects. When we attempt to use any fileshare (in this case Acqlite), it also never connects. Yahoo, AIM, doesn't matter--it can't connect. The fileshare never shows any successful connections negotiated with Gnutella, Limewire, anything.

What's worse, I hadn't used my PowerBook in some weeks--and now when I turn it on to see if there's a difference, it too cannot connect on fileshare or chat, even though it did previously and I've changed nothing on either my desktop or laptop configurations in all that time.

So here's what it boils down to: neither my old PowerBook running Panther nor my roommate's iBook on Tiger can fileshare or chat, however both can receive signal perfectly fine for internet surfing.

A friend suggested that while my desktop runs as a DHCP setup, I should turn this off on the laptops. Doing so, however, rendered them completely unable to even surf on the Internet. So I switched them back and all three computers in this network, desktop and two laptops, are set to "Using DHCP" in Network configuration panel.

Another suggestion was to use the AirPort Admin Utility to set up a 'bridge' arrangement, which as I've said before I cannot do because the Admin Utility only recognizes stations, not the card set up inside the tower to use LIKE a base station. So no go there. Anything I change is going to have to be done in network settings on one or all of these machines (that, or someone needs to explain to me how to make the Admin Utility recognize my own desktop broadcast).

What few things I've changed only seem to kill reception of the signal at all, and beyond that I know of nothing I can do to get these laptops fully functional on the AirPort network--which is especially frustrating to me because of the fact that my PowerBook previously worked fine and has stopped for no apparent reason. I have renewed the DHCP lease on all three and no apparent result from this.

I would have thought it was a compatibility issue between a Panther AirPort and a Tiger laptop, however my PowerBook is running Panther same as the desktop.

Any solutions, suggestions, diagnoses? I would greatly appreciate any help, thank you.
The problem lies on your routing desktop mac. For testing, try to turn of any firewall options. And how about your desktop Mac, which is routing the broadband connection? Does ichat and other apps connect?
I am not very familiar with the Ad-hoc method you seem to use. But why aren't you going for a wifi router, which is currently at a cost of maybe 40€ / $40? Now that you have few computers using the same wan this is the smartest and cheapest step.
And welcome to the forum.