Angelbird Crest SSD for Macbook Pro Issues

teejten

Registered
I bought and installed an Angelbird 240gb crest for Mac SSD. I have a late 2011 MBP and 10.8.4 Mountain Lion. After I installed my SSD i got my computer up and running, after about a week I checked the system report and I found that the negotiated link speed was at 3gb. I did a ton of searching through forums, google, everywhere I knew to look and I found 1 useful tip. That tip was to reset my SMC with the shortcut shift+ctrl+option+power when the computer is turned off. I did that and it worked, I got my negotiated link speed back to 6gb. However, I shout down my computer and booted it up the following day and checked the system report again only to find that the negotiated link speed had went back to 3gb.

I contacted Angelbird and they didn't know what the issue was or how to fix it. After two weeks they suggested that I update to 10.8.4 Mountain Lion. So I did and after I updated I checked the system report and the negotiated link speed was at 6gb. I thought that fixed the problem because I shut down my computer and when I booted back up the negotiated link speed was still at 6gb. Then I went to work the next day and noticed that it had went back to 3gb on that boot. I went to About This Mac and noticed that there was a software update for Mountain Lion so I updated and viola, issue fixed. However the next day when I turned on my computer the negotiated link speed was back at 3gb.

So I contacted Apple and the same shit happened with them. They don't know what the issue is or how to fix it so they submitted a ticket to the engineers. I am out of ideas on what it wrong or how to fix it myself. Anyhow, when I was on the phone with Apple I recreated the issue and save the spx files as I went along. I repaired disk permissions and it didn't help so I went to more info on my Angelbird SSD and changed the Wheel permissions to read/write and rebooted, it didn't help so I ran repair disk permissions again in Disk Utility and I got a couple of lines of information about the Wheel settings being wrong. After Disk Utility was finished I changed the permissions in more info back to read only and rebooted. It took me 3 boots before I got it back 6gb but the boot right before I did get it back to 6gb, the negotiated link speed was at 1.5gb?

Last night I unplugged my Angelbird SSD and plugged it back in checked for loose connections again, etc. When I booted my computer it wouldn't recognize my harddrive so after about a half hour of booting, nothing. Then I unplugged and plugged my harddrive in one more time and now my computer has a negotiated link speed of 6gb. Everything is working fine but I am scared to turn my computer off for the fear of the negotiated link speed decreasing or my harddrive not being found.

Will someone please help me, by help I mean suggestions, information, anything is considered help at this point because I have no more ideas. Sorry for the long post, I tried to keep it as short as possible but it's been one heck of a ride since I installed my Angelbird SSD.

Thanks for reading!
TJ
 
Top