*Another External HDD Problem! -Mac/Pc


I have a 120 Gb Seagate Ex. HD that I use to store everthing from my pc on. A couple weeks ago I bought a Powerbook G4 and put some stuff from the HD on it and everything worked fine. Later that night I turned on the Pc again and the HD showed up as RAW. It took me a while, but with GetDataBack I got everything that was necessary off the HD and put it onto the the Powerbook. Since I only had 5gb of free space on the Pc I had to put it on the G4. The only way to get things to the G4 from Pc was by the 4gb iPod.
I finally got everything off of it and formatted the HD to 2 60gb partitions in Fat32. I hooked it up to the G4 and and put a folder or two on it just to test and tried it out on the Pc and worked well. I decided that I might as well just make it 1 120gb partition if it works. So I go ahead and try but now it is not being recognized on the G4. Now it never shows up on the
desktop and Disk Utility takes forever together info!
On Pc, SwissKnife V3 was the program that worked at first and its the only good program I could find to format the HD to Fat32. It works perfectly after I format it on Pc but the Mac isn't recognizing enough to write to it. I really don't wanna have to do the whole iPod thing again back over to the HD, could you help me out? Thanks!