Anyone have problems in OS X with Epson 740

pmangiafico

Registered
Has anyone experienced any problems getting an Epson 740 (USB) working under OS X? I know its supported and it even shows up in the Print Center, but each time I attempt to print from an OS X application, I get an error message telling me the printer is offline or off (communications problems). The suprising bit is that I was able to print from Microsoft Word (within Classic).

I'm using the latest version of OS X and the latest update of the Epson print drivers.

Thanks,
Pete
 
I have only seen this problem once. my 740's USB cable was plugged into a USB hub and not directly into the back of my 733. Plugging it into the back of the 733 solved it.

This was in X. Haven't seen it or used that setup (plugged into the hub) before in pre-X. Just had to do it cuz the USB cable wasn't long enough to reach the 733 when I rearranged my desk.
 

Lüftwaffle

Registered
Well, I've got an EPSON 1200 and it categorically refuses to print under OsX. Well actually it's OsX that refuses to recognise the printer. Prints fine under Os 9.1. Any ideas?
 

pmangiafico

Registered
Well, after much finagling, I stumbled upon something which may help you get your Epson printers recognized. All of the other suggestions didn't help (i.e. plugging USB straight into the iMac instead of a hub, re-installing the printer drivers, unplugging any unused peripherals, etc.). But what finally got it was disabling the "admin" access for the account that I need to print from. That's right! Its 100% reproducible. Set up another account to act as admin, disable admin on your account, and the Epson printer magically appears in the list. Enable admin for your account, and the printer disappears. Wow. (Switch admin on and off from the Users menu in System Preferences). Curiously enough, if you enable the root account and login as the root, you can print fine too.

Hope it works for anyone else that has this annoying problem.
 

Cubester

Registered
pmangiafico,

I tried your tip; created new user, assign admin, deleted my admin account, and tried to print. Nothing! I can print on my 740 in OS 9, no problem. But in OS X it works only 30% of the time. I'm thinking I'll call Apple Support on Monday and have them spend cycles on this since both Apple and Epson claim the drivers are part of the OS.
 

edX

mac shaman
I'm just guessing here, but just for sh*ts and giggles, try moving your dock back down to the bottom. First my girlfriend couldn't get her 777 to be recognized by the print center. I then tried to print on my 740 and while I got recogniton, I got no printing. this was accompanied by other wierd abnomalies in appleworks 6.2.1. Went to apple support group and sure enough there were lots of posts about this problem and the one universal cure seemed to be putting the dock back to the bottom. I've put mine (and hers) back and haven't moved them since. I've been seeing less general anomalies ever since. We print just fine now. Well, everything except old, large appleworks files which I will go back to 9 for if i need to print them before the bugs get exterminated.
 
did (and saw) the dock trick mentioned. No joy here.

But as of about a week and a half ago, I can print fine.

There is ONE thing.... and I think it is related to the printer itself. now I get these awful scraping/grinding sounds from the printer while beginning a print job. (I don't print often from my printer - my wife does and I'm starting to hate the calls for end-user support to me from my wife, I carry .pdfs, etc on portable media and if I NEED a hardcopy I send it to doc productions at the firm and they run off a professional copy).

It's odd how this thread just popped - I just mistyped the previous "popped" and spellcheck just suggested pooped... hehe) back up... Anyone see this? I can usually get it to print a copy after the 2nd or 3rd try and doing all the printer head cleaning, troubleshooting suggested, etc....

It's scary grinding... like a little chain saw...

Also, since this has been happening, I need to keep switching ink carts much more frequently. Probably just ned to buy a new printer. We did get this one when the iMac originally came out - wow! We still have the pretty bondi-blue in a box. I was thinking, if we have a son (due in April-May and we'll know the sex nov 21), I could set it up in his nursery. Ya know, start him off early... it's blue...

Anyone have any ideas or a good vodka tonic? (ran out of tonic - how could I!?) Looks like it's straight Beautiful Polish Vodka for now...:rolleyes:
 

edX

mac shaman
Cubester, I don't really. But problems with printing as well as several other appleworks specific problems can stem from mounting it on the side. If you are having these kinds of problems, then it goes to reason you have moved your dock to one side or the other. If you have and you move it back and things work right, then it was what you needed to do. Unfortunately it is not always the problem. Besides my guess is that about 90% of the people who like to use a full size screen pages for any program have moved it and hidden it. It is so annoying taking up space and whenever you go to do something like scroll from the bottom, it tends to pop up when hidden. So we moved the thing to get it out of our way. Turns out it is the wrong move for some purposes. If apple doesn't (or can't) fix this one soon then I will be puzzled as to why they don't care or why they even bothered to let us move it in the first place if it doesn't work right that way.:confused: not really like them.
 

twyg

Back to Mac Baby!
now I get these awful scraping/grinding sounds from the printer while beginning a print job. (I don't print often from my printer - my wife does and I'm starting to hate the calls for end-user support to me from my wife
Well, obviously the 'ol lady broke it... :p

On a serious note, did you check the track? Sometimes a little sliver of paper somehow gets stuck, and it's just enough to cause the "barking" of the ink shuttle. Now that I said that, is it the ink shuttle at all, or the rollers?

The easiest troubleshooting is the one you already mentioned. Get a new one... (There are some really great printers out there, but that's for a whole other thread)
 
Top