Anyone using UFS?

brianleahy

Colonel Panic
I just reinstalled OSX on a UFS partition. I've had problems with -43 errors when doing different disk operations. I downloaded the new Stuffit/SMI file for OmniWeb. I opened the smi file, and then tried to drag the OmniWeb application into my Applications directory - and blam, -43. At one point I put some stuff in the trash and was getting -43 errors when I tried to empty.


Finally, I downloaded the gnutar.gz version, and followed the directions to install it -- and that worked fine. It looks like there might be an incompatibility with Disk Copy SelfMountingImages and UFS drives.....?
 

Gorbag

Registered
I had a number of problems using UFS on my bronze G3 Powerbook.

Classic didn't work; this is apparently fixable, though I didn't know that until I had already gotten my machine working by installing OS X on HFS +. (Apparently you have to copy the classic application to an HFS+ partition before launching classic). Intuitive - NOT.

The bigger problem, and why I couldn't see the solution in the Mac Help files for Classic, was that virtually no help file would display. Either I would get an error that the html file was not found, or help would simply exit.

After reinstalling using an HFS+ based partition, I've had no further problems along these lines. I recommend avoiding UFS to install OSX PB until support has improved significantly.
 

rosignol

Registered
I think UFS lacks support for certain resources/data that HFS/HFS+ stores in the filesystem. It might be suitable for people running pure MacOS X with no need for compatibility with the classic environment, but I don't think it's the recommended option for most users.

 
Top