Apache config Q / symbolic links Q


I want to use Apache to serve a website we run strictly over our local network for testing. I've figured out how to get most things setup the way i need them, and I can see the pages from other machines no probs.

Just one thing I'd like to know if i can fix: the working folder for the site is in the desktop folder of another volume (my 9.1 startup volume - we still do the actual work in 9.1). It would be a hassle to change this as various apps and various people expect to find it there. So at the moment to get the site served over the network I have to copy all the files from that folder to the "WebServer/Documents/mysite" folder where "mysite" is the folder I have created. This is a PITA, and I'd love to be able to serve directly the working folder. I've tried 2 ways to do this, neither worked, and I'm a *NIX newbie, so I'd be v. grateful for any help anyone could give. Briefly, I've tried:

i) Editing the "DocumentRoot" entries in the httpd.conf file. I can get this working within the boot volume, but as soon as I try to specify the other volume with "/Volumes/MyDrive/Desktop\ Folder/Website\ Folder/mysite" I get a server error when I try to connect ("cannot find file" IIRC). I've tried various combinations with "/" at the beginning or end of the path, and tried "%20" and " "instead of "\ " for the spaces (i know that "\ " works in the terminal, I can cd to the directory I need) - but like I said, I'm a newbie at this, so I don't know if that was a waste of time? Anyway, I couldn't get it to work, so,

ii) I tried aliasing to the website folder, using aliases of the folder or files within it in the "Webserver/Documents" folder, many combinations, also checked permissions etc. no joy. So I read about symbolic links, but can't get one to create for the path I need in the place I need it. There is a link in the "/Documents" folder already - "manual" which goes to the Apache Docs. I can copy that and rename it, but when I change it's original using the finder's 'get info' panel, it disappears, presumably because I have broken it, and I don't really understand enough to know what I am doing. I'm at a bit of a loss.

So having admitted my ignorance, can someone help me out here? Either to change the config, or I'd prefer, to make symbolic links to the folder we work out of if that is a possible thing to do?





echo $row['what_tha'];
I have the exact question you do, and it seems that few people that may no the answer have been by and read your post....

I was wondering if you found the answer else`where if you could let me know?



I was able to successfully set DocumentRoot to a volume (my OS9 volume) as such

DocumentRoot "/Volumes/MacOS drive/Documents/WebPages"

Note, no backslash or %20, just normal, and in quotes. See if that works.