apache will not start

jazzy

Registered
Okay, I installed the release version of OS X 10.0 and everything seemed to be going along nicely. However, now that I am trying to start up apache and migrate my websites back onto this machine, I have hit a snag. So here it is...

I configured the httpd.conf file with all of the relevant information (ServerName, VirtualHosts, et cetera) and I was able to verify that the syntax is correct with the /usr/sbin/apachectl configtest command. But, when I try to start apache, I get the following dump:

> Processing config directory: /private/etc/httpd/users
> Processing config file: /private/etc/httpd/users/uername.conf
> /usr/sbin/apachectl start: httpd could not be started

What is it doing with the /private tree? Incidently, I su'd to root to modify the file and to start (or at least try to start) the httpd service.


Granted i have only worked with apache on a purely recreational level, but I have never seen this come up. Does anyone have any ideas?
 

jazzy

Registered
So by removing the include at the bottom of the httpd.conf, the included config file no longer is checked. However, I still get there statement that:

> [localhost:/etc/httpd] root# apachectl start
> /usr/sbin/apachectl start: httpd could not be started

Any thoughts?
 
Top