App Crashes Develop Into System Shut Down


We have 1.25 ghz eMac, 512 mb ram, and 160gb hd, on OS X 3.9 The RAM is original Apple installed. It started throwing up this message telling us of the need to shut down and restart the computer. Things have only gone from bad to worse - mostly with iApps ( that were never moved from original locations ) Safari would run, but not iPhoto, IMovie HD, etc. Used disk utility to repair permissions a few times - even using original dvd as startup and repaired permissions. Tried DiskWarrior 3.0.2 but it quits part way through its routines, not always at the same place, and the computer starts up from its own sys folder again. Family account logins continued to work correctly, but no one could get the troublesome apps to open. Toast Lite worked for quite a while and was able to burn of a couple of dvd's worth of iphoto libraries. Then even that started to quit. Tried a Tiger DVD to start a system update but it quit when checking the drive with an error ... please try again.(had the same results when tryiing a reinstall from PAnther DVD) When the original eMac PAnther startup DVD was in we tried the disk repair - it reported B tree problems - but couldn't fix them. Thought that's what disk warrior was good at but does it sound like the hard drive is toast or should I wipe it and reinstall PAnther or Tiger - I would prefer PAnther. The computer will not even start up now - just the grey apple logo with the stick wheel spinning under it. It will probably do a target startup off my iBook - perhaps I can get a few more files, but will they be reliable ? Will Disk warrior eventually succeed if one keeps trying ? The DVD drive continues to work and the computer will startup from a DVD. Any suggestions ...sorry for the ramble. ( I did take a digital pic of the eMac screen when one crash produced some command line error messages overlaid on the display.)
Thank you for any suggestions - really hate to give in and reinitialize the drive. - Dave
If DiskWarrior can't repair the drive, you're only alternative is to wipe the drive. Boot from the Panther disc and sue Disk Utility to format the drive.

After doing that, before trying to install Panther, use Disk Utility to repair the drive to see if there are still any errors.

If there are, boot from DiskWarrior and see if that will run completely and successfully. If not, replace the drive.
Thank you for the response Bob
When I first tried disk warrior it would report that memory limitations were slowing down its performance. With 512 mb of ram, could this be possible - or might I have bad ram ? I have erased the drive now but on first attempt at reinstalling the system the install quit early while preparing language packages and went to a blue screen with spinning stick wheel. I had used disk utility to repair the disk after the erase, which it did with no error messages, but haven't run disk warrior again yet.
Diskwarrior replaced the directory successfully. Reinstall of 10.3.3 went fine. Repaired permissions and set of to use Safari - which promptly quit as soon as the window opened. Tried software update and it quit unexpectedly too. REbooted and repaired permissions again - lots more repaired this time - esp the same old color sync references - and rebooted. Out of curiosity I checked the 'about this computer' note and saw that the computer is reporting only 256 mb of ram. I rebooted again and several times since but it is now reporting back to the 512 mb ram. Ran software update successfully so am back to 10.3.9 etc. Would it hurt to try the 512 stick in the other slot or should I consider swapping in a different stick , and if so is DDR pc 2700 133 dimm what I am looking for ? THanks for your continued monitoring of my replies Dave