Appleworks Applescript



I am trying to get an apple script that I have written to run on an Appleworks spreadsheet. (Script Editor 2.0 Appleworks 6.2.4 G4 running OS 10.3.9)

When I run the script from the Script Editor with the Appleworks document open, it works just fine. The script copies numbers into new cells and then sorts the cells numerically.

I saved the script to the Appleworks 6 => Essentials => Scripts folder and quit and restarted appleworks (and over the course of time, have restarted the computer several times as well). When I call the script from the Script menu or from a macro code in a cell I get this error message: An unexpected error occurred. #-12380.

I have even tried writing bare bones scripts to see if they would run but get the same error.

I downloaded a script from the internet and installed it and it runs just fine. I've tried taking appropriate sections of that script to create a new script but get the same error again.

Can you tell me what I'm missing?

I'll make this post short as I've figured it out thanks to having you around to bounce off ideas and make me look at it all one more time!

I was putting together this response with the requested scripts and wrote the following:

... and can't even get that to run once I've saved it as a script though it runs through AppleScript just fine. Maybe I'm saving them incorrectly?

Aha! That's it! I've been working on this for weeks... Thank you for responding to my question -- I've been saving them as "scripts" but I need to save them as "applications". It works now!

Thank you!