Applications Always Open As If It Was Their First Time


After every restart, almost any application I open shows the message "You are opening the application "Whatever" for the first time. Are you sure you want to open this Aplpication?". I've repaired permissions and run every disk repair utility I know, but the problem persists. Any ideas?

I think it was with a specific system version/build that Apple tried that out. What version are you using and can you update through Software Update?
'After every restart ...', why so many restart's (reboots)? Restarts (reboots) are typically performed after an Apple System or Security Update, some third party software installations, when Apple's 'Safari' freezes MacOS X ('Tiger' only), plus a few other circumstances.

'... almost any application I open shows the message "You are opening the application "Whatever" for the first time. 'Are you sure you want to open this Application?'' - This is a 'Tiger' feature.
A constantly restarted, and not properly shutdown, Mac - should not be expected to operate (behave) as expected and save the files it needs to, during the shutdown process.

'I've repaired permissions', which have no effect on the problem stated, '... and run every disk repair utility I know, but the problem persists. Any ideas?'; but, you never explicitly state the names of the utility applications you used; nor, how you booted the Mac - in order to perform such disk repairs. Also, if you restarted (or even, just booted) the Mac and attemped to 'Repair Disk' via Apple's 'Disk Utility's 'First Aid' tab's panel - you cannot. 'Disk Utility' cannot repair the boot drive; but, you can (repair) other (non read only) volumes.
To repair your Mac's boot drive - you must boot from your (unknown version) MacOS X installation CD / DVD or another bootable volume, and run its 'Disk Utility' application - select your Mac's internal drive and then click the 'Repair Disk' button.
I'm running 10.4.2 on a 867 Mhz PowerBook.

I run Software Update weekly, and I just checked again, but there are no new system updates offered.

I Restart after new software installations that require it, and about once a week to give it a fresh start (an old Mac habit I haven't lost). All the Restarts are initiated from the apple menu, and run smoothly. I haven't needed to Force Quit any apps or force reboot with ctrl+cmnd+power for months (that's a problem I have on my new 17" PB, where the Finder occasionally gives up, with Relaunching not fixing things, but that's another story...).

I repair file permissions with Disk Utility, having booted from the usual main drive.

I ran both Disk Utility disk repairs and TechToolPro 4.0.5 after I booted from a clone backup drive I have.

The "You are opening the application "Whatever" for the first time." message only happens once after each reboot, and not with every application (a couple of the ones that produce the message are FileMakerPro 8.0 and Excel (Office 2004), and no Apple apps do it). The icong for document files of FileMakerPro are blank every time until after I run it.

Are there any preference files I could trash to reset things?

Thank you so much for taking the time to help, I very much appreciate it.

Must say, I'm flat out of ideas currently. I clearly remember those messages, but haven't seen them in a while... Maybe I've seen them in betas of Tiger - but not in final versions... Don't remember, really. I can only state that for me it clearly doesn't happen in 10.4.2...
You probably have a corrupt cache file (or two …)


If you have more than one user, you'll see "502" etc as well as "501".

Unfortunately deleting these will mean you will get this message for all your applications, but only once each.
YES! That did the trick. The interesting thing is that next to the files you named I found this one: . I deleted that one as well, restarted, fixed permissions, opened a few apps which gave me the usual error message, and the document file icons got reset, and after restarting again, everything works great.

Thank you.