Applications folder lost permissions...

ari

Registered
I don't know if I accidently did anything but..... my applications folder in the root directory of my OSX partition will not let me modify it (adding folders, icons, etc.) but any subfolder under it allows me to do anything i want. I tried resetting the permissions both in the finder inspector and in the terminal (using chmod) but nothing has helped. Yes, I'm logged in as an administrator. Is anyone else having this problem? Any solutions?

Thanks.

Ari
 

VGZ

Registered
Open the terminal and check the permissions with ll after typing cd /

You can change the permissions with chmod (man chmod for more info) or change the owner of the folder with chown.

I changed the owner to myself to prevent problems. Type sudo chown YOUR_USER_NAME /Applications
to change the owner to your user (you will have to type a password).

Good luck,
 

ari

Registered
Thanks.... it did the trick. Any ideas why it would do this? I can't ever remember changing the permissions on that folder and it was working fine since I installed it until just a couple days ago.

Whatever.... all's well.

Ari
 

cqoverly

Registered
Ari,

Do you have the Kensington Mouseworks beta2 installed? I recently learned that it was the cause of my own application priviledges woes. They have beta3 now, and it solved the problem for me. No more root.

CQO
 
Top