Apps Not Opening/working

dae

Registered
Heya,
First of all thank you for providing this service, it is very much appreciated.
Okay, I first noticed that there was a problem when Preview and Textedit started not to work. What I mean by that is that if I clicked on them in the dock, they would open however I am unable to open any existing files with them. If I try to either open a document or open one by going through the 'open recent' menu the application stops responding. Espicaially when Preview stops responding, then the dock freezes up as well (although after a while, maybe 5 minutes, it comes back to life). I haven't noticed any other programs not working, however windows media player seems not to be able to load anything either. As far as a can tell, this is the extent of it for now.
I've recently installed Adobe CS2 and I was wondering if that might be causing problems, however if it is, it didn't immediately happen after the install. I've tried a virus checker which found some viruses in my Java cache, although they were all zips and so I assume they were for windows or inactive.
I have an eMac running 10.3.9 (I'm not sure what specifics you need here, so tell me if I've left something out), with a 1.25 GHz G4 processor and 512 MB DDR SDRAM.
I think that's everything, and again thank you for your time and assistance.
 

Zammy-Sam

Desertchild
Hi dae and welcome to the forum.
Did you repair your disk permissions? Open Disk Utility and mark your os-volume to repair disk permissions. If that didn't solve your problem try to setup a new user-account to see if your apps behave the same way on a fresh account.
 

dae

Registered
Hi Zammy, thanks for replying, yes I did repair disk permissions and that had no effect. I would try and see if the apps work in another account, however for whatever reason they've mysteriously (and thankfully) started working again. They haven't worked for an entire week and have only just now begun to operate as normal. The only thing I've changed in this time is freeing up some space on my hard drive (I went up from 2 gig free to 18 gig free) about two days ago. All I can think of is that they needed a rest, but of course that makes no sense at all.

The whole thing has me a little worried and I think I might back-up then reinstall just in case...
 

cdubks88

Registered
dae,

You might try to navigate to your user home directory (whatever user you run under), and then to Library > Preferences.....find the com.apple.Preview.plist and com.apple.TextEdit.plist files and drag them to your desktop (make sure both apps are closed when you do this). Then try to start them one at a time and see if you can open files without the crash......

Could just be a corrupt pref file.....

Just a thought before you go to the trouble of reinstalling.

Take care,

C.
 

dae

Registered
You know, my computer fixed itself and I didn't worry about it anymore. But then Preview started playing up again and I followed your advice cdubks88 and it worked. So thnk you very much :)

This begs the question though, why does this keep happening?
 
Top