aqua theme on tiger ichat...ichat ruined?


I am using 10.4.2 and I just installed the ichat aqua theme which I had from Panther. I did not check to see if it worked in Tiger and it did not. ichat does not work at all. I deleted the program and everything from my users>library>preferences folder. I reinstalled ichat from my Tiger disk and it still does not work. How is this possible and how do I fix it. Another poster asked this question but it was not answered. Please help, Mady
Yes I repaired the permissions and it did not change anything. I deleted all the preferences and tried reinstalling using the Tiger disk and by using Pacificer. Nothing worked.
Try re-applying the 10.4.2 combo updater. iChat has seen some updating in this latest update (and possibly in the 10.4.1 update, too). If you just take the iChat from 10.4.0, that might not work with the updated frameworks of 10.4.2.
If the theme was a separate program, it probably modified some things in the frameworks etc, places where manually it's hard to know what should be where and how.
As far as I remmeber having seen, the only 'aqua theme' was something like Demetallifizer, which worked with APE. Was that the one you were using? As on the program level, it has to find where actually the theme is set to be metal or aqua, it could take that information e.g. from the frameworks. (I remember having changed the look manually for some application ages ago, so don't remember any more where it was exactly. If it wasn't in frameworks, free feel to correct).
Anyway - if it is on the frameworks where it changed stuff, you'd need to try the combo update. You could try update_prebinding as well, in case it would be just some program parts needing to be relinked.