ATI Update causes screen glitches

slur

Geek / Hedonist
I just updated the firmware in my two ATI cards in my G4, a Radeon Mac Edition AGP card I installed to replace the OEM Rage128 card, and a PCI XClaim Rage128. Following ATI's instructions I placed the ATI ROM Extender file into the /System/Library/Extensions/AppleNDRV folder. But while moving over links on this very site there was a square of graphical glitches around the mouse pointer, only on the display attached to the Radeon card. (22" Cinema Display connected through a DVIator adapter.)

In the past ATI has recommended removing one or more cards when updating drivers, but I haven't tried this yet. However removing the ATI ROM Extender file has eliminated the graphical glitches.

Has anyone else had a similar experience with this extension and a Radeon card, AGP or PCI? I'd be curious to see if there's some way to fix it. I'll try removing the PCI card and running the updater again tomorrow and report the results. My prediction: Nothing will likely change....

According to Apple System Profiler my RADEON now has ROM 113-74901-117 while the VR has 113-57406-108. Hmm... Does this mean anything?
 

technodom

Registered
Same problem here, lots of little black squares that follow my mouse, but your luck really, i have two monitor and the second card is a Formac which worked fine under 10.0.4 but now nolonger works at all!!! help.. Oh and if anybody speaks to Formac - should be NotForMac - all they could say was:

"Really oh well, we don't have any drives for OS X", when will they be ready? I ask "we haven't started them yet" any other ideas then? "use another card!" well, if thats there attitude, they aren't going to be in business for much longer!!!

Any ideas from you guys and girls as to how to get the other monitor working?

cheers

TechnoDom
 

Mongrel

Registered
I've got a G4/400 AGP, with the AGP card removed (it was noisy!) with a PCI Radeon. Did the update just right, having the same problem. I've sent a message to Macfixit.com first thing this morning, I suggest anyone else having the problem do the same.

By the way, the problem only happens over chunks of plain text... the cursor is just fine over graphics and even LINK text... odd. I'm wondering who needs to provide the fix for this, Microsoft or ATI... if either that is:(
 
Top