Authorization API Meltdown

maxgleeson

Registered
Hi all. This is my first post on this forum, and I come to you in need.

I have a penryn macbook pro running 10.5.5 that is preventing me from doing a lot of things. I can't install most software– an installer program will ask me for my authorization code and then silently quits when I put in my password. This doesn't affect Installer.app, only third party frameworks like VISE or adobe's setup.app.

I can't run third party system utilities. CarbonCopyCloner will ask for authorization and then hang while "searching for disk permissions" until I force quit. Other programs like cocktail do the same thing.


Trying to install using VISE
Code:
com.apple.SecurityServer[18] Failed to authorize right system.privilege.admin by client /Volumes/FileMaker Pro 9.0 Trial/FileMaker Pro 9 Trial Installer/FileMaker Pro 9.app for authorization created by /Volumes/FileMaker Pro 9.0 Trial/FileMaker Pro 9 Trial Installer/FileMaker Pro 9.app.

Trying to install Adobe CS3 through Setup.app:
Code:
KernelEventAgent[23] tid 00000000 received unknown event (12) 
[0x0-0xec0ec].com.adobe.Installers.Setup[2079] Begin Adobe Setup 
[0x0-0xec0ec].com.adobe.Installers.Setup[2079] UI mode: Full GUI 
Setup[2079] Calling AuthorizationExecuteWithPrivileges 
Setup[2079] AuthorizationExecuteWithPrivileges failed with status: -2129264641

Trying to repair permissions on my startup disk:
Code:
ACL found but not expected on "private/var/root/Library/Preferences".
ACL found but not expected on "private/var/root/Library".
Group differs on "usr/libexec/security_authtrampoline", should be 0, group is 80.
Permissions differ on "usr/libexec/security_authtrampoline", should be -rws--x--x , they are -rwsrwxr-x .
Warning: SUID file "usr/libexec/security_authtrampoline" has been modified and will not be repaired.


security_authtrampoline, SecurityServer, AuthorizationExecuteWithPriveleges are all failing. I've already completely reinstalled my system, which fixed the problem for a while until it came back. Now I've noticed that it is happening on several machines at my workplace, all running 10.5.2 or later.

I'm so lost... This has been eating up hours of my time, plus days of lost work not being able to install Photoshop and other important apps. Has anyone experienced anything similar?
 

Satcomer

In Geostationary Orbit
Well it sounds if you really screwed the pooch on this one. First off i sounds as if the master password has messed up. Use an OS X install disk you can boot with that to reset the master password or follow out forum [HOWTO] Reset User Password via single user mode to hack the password.

Now it sounds as if you never ran ANY maintenance on that Mac. Have you been running maintenance on that Mac? You know if you run either Yasu or Onyx and run all those cleaning routines once every four weeks. It is wise to restart your Mac twice after running those scripts to rebuild the startup/shutdown cache.

Also did you read the Macworld article Bugs & Fixes: A new solution for permissions problems?
 

maxgleeson

Registered
Hi Satcomer, thank you for your reply. I've always run maintenance scripts regularly, and I've tried all of those fixes in the course of investigating this bug.

No luck so far! I think I will have to back up my data and restore to a fresh 10.5.2 install. Oh well. I wish my mac just worked, like they used to.
 

Satcomer

In Geostationary Orbit
Before a whole wipe download the 10.5.5 Combo (it's HUGE so don't be alarmed) and apply that. It may help.

Warning: Let the Combo start normally because it WILL reboot twice to install some Security files. DON'T interrupt it!
 
Top