.AVI playing on iMac G5

NarutoSasuke

Registered
Okay, I was wondering, I have an iMac G5 with a Radeon 9600 video card and I have a Windows machine that has a GeFORCE 2 (with 32 MB VRAM!!!) and honestly, when showing my friends .avi files on VLC, the video sucks!!! It's choppy, it freezes up sometimes, is it just VLC software, or is it the iMac? Just wondering, does anyone know how I can fix this problem?
 

Mikuro

Crotchety UI Nitpicker
I don't know why VLC wouldn't play it right. Your machine is definitely powerful enough. You could try MPlayer instead. Better yet, install the Divx codec for QuickTime. (If version 5 doesn't work, try the Divx 6 beta).

But VLC really ought to play just fine. It's possible some important settings got messed up, so you might want to try resetting your prefs (there's a reset button in the VLC prefs window).
 

NarutoSasuke

Registered
Well, I doubt the preferences is a problem, I've reset them twice and I still get the same problem. Okay, just so that you know, I've restarted the Finder so that the widgets get reset and don't take up any Virtual Memory, HOWEVER, I'm running Firefox, streaming iTunes Radio, and downloading 6GB over wireless connection. All of this with 512MB RAM and trying to watch the movie full-screen. (I NEED IT FULL SCREEN!!) However, with a Radeon 9600, should the VRAM take care of the video processing and encoding. Gosh, my freakin' Pocket PC plays .avi's better than my iMac G5!! Do you have a better idea of what might be the problem?
 

Mikuro

Crotchety UI Nitpicker
Your graphics card isn't really the dominant factor. Decoding is mostly done in the CPU. If you're running a lot of downloads, disk speed could be a limiting problem.

Disk access is my best guess. My old 450MHz G3 iMac played AVIs pretty well, and it had a mere fraction of the power of your system. However, disk speed will always be a bottleneck for these things. Too many downloads going kills performance like nothing else. And IIRC Acquisition is especially bad in this sense.

By the way, the Finder doesn't control Dashboard widgets. That's actually handled by the Dock. If you want to keep them out of your way, the best way is to open Dashboard, and close every single widget inside. Then control-click on the Dashboard icon in the Dock (if present) and remove it (F12 will still trigger Dashboard after this). Most of the standard widgets included in Tiger don't eat many resources in the background, though, in my experience.
 

NarutoSasuke

Registered
Thanks for that help, but I thought there was a way to reset widgets and take them out of memory. For instance, can't you restart Dashboard and cause the wiedgets to reset and be out of memory?

The disk access makes a bunch of sense, if only they put 10,000 RPM drives in iMac's... but that sounds right. Extra RAM would allow me to run movies more smoothly while still downloading stuff, right?
 

burning_jonny

Registered
First, sorry for replying to an old thread, but I feel like I am in the same boat.

I am using the latest VLC 0.8.4a, and full screen or not I get the same thing where the movie will 'freeze', and then unfreeze a few seconds after. I usually miss the good stuff when it freezes.

I also have an iMac G5, 2 GHz, with 2 gigs of RAM.

I don't have a lot of apps running ayways...but I've been having the problem every since I go the pc. Reformatting didn't help.


Jonny


PS
mplayer plays good, but it's UI sucks.
 

Porce

Registered
I have to alternate between QuickTime and VLC almost weekly to play not only AVI's but MP4's and MOV's. It seems the video gets all choppy in one player and then the next week it works fine, while the other player seems to choke on everything, and then back to the other way around the next week.
 

burning_jonny

Registered
Seems like VLC is not all it's cracked up to be. It still is my favourite.

I know I could just use Quicktime once I've installed all the codecs. Or Mplayer plays video well, but VLC's shortcuts are better, UI is better, and the playlist isn't goofy.

I wish there was a way to figure out how to get around these glitches in VLC. Do they even admit they are a bug?
 

fryke

Moderator
Staff member
Mod
Make sure that in Energy Saver, the CPU speed is not set to automatic, but to highest. I've had lots of choppy video when it was set to automatic, so I guess it somehow doesn't "get" that it has to give more CPU power when decoding video in VLC, if it's set to automatic.
 

TiTAN io

Registered
When exporting to avi from good video (4.2.2 etc) I get repeated frames every once in a while as if there was some frame rate conversion going on. Does anyone know about this issue with avi files?
ZNKS to all
 

burning_jonny

Registered
Ya, I have the processor performance set to 'highest', but no luck. I don't know why it happens only in VLC, but I've decided that I'd also take route of alternating between Quicktime and VLC.

It's funny, I never have this problem on my G4 iBook.

Maybe it's processor optimization or something like that?
 

Mikuro

Crotchety UI Nitpicker
TiTAN io said:
When exporting to avi from good video (4.2.2 etc) I get repeated frames every once in a while as if there was some frame rate conversion going on. Does anyone know about this issue with avi files?
ZNKS to all
What is '4.2.2'?

Are you sure there isn't frame rate conversion going on? Many encoders are not smart about this, and require you to manually enter the target framerate.

It might also be that your source format uses a variable frame rate, which AVI does not support. I've seen this happen with certain TV shows that use both 23.97 fps (NTSC film) and 29.97 fps (NTSC TV) for different parts. Encoding those properly into AVI is not easy. But I have no idea what you mean by "4.2.2 etc", so I'm not sure if that's relevant here.

Jonny: Have you ever tried using MPlayer? It can play just about everything VLC can. VLC performs better sometimes, and MPlayer performs better sometimes. It's worth checking out. (The link is in my sig.)
 

TiTAN io

Registered
Sorry, 4:2:2 PAL broadcast video, 4:2:2: referes to the way luminance and chroma are sampled (as in DV 4:1:0, 4:2:0 ...etc); I siply meant that the source material is extreme good quality. I´ve tried setting manually the frame rate, and also leaving it to automatic, but i´ve found no way to get the right avi export. ....znks
 

burning_jonny

Registered
Thanks Mikuro,
I have tried Mplayer, and use it sometimes. I just can't stand the GUI and the way it behaves. Other than that, it play video pretty good.

Jonny
 
Top