avi's finally play!!!!!!

whitesaint

cocoa love
I tried out the new "Divx for OSX" and it actually works! I tried it under 10.04 and it worked, but it worked ALOT BETTER under 10.1. There is one problem I'm having and that is with sound. The .avi movie file plays fine except the sound skips an awful alot. I put all 3 files i got in /Library/Quicktime/. Im not sure if this is right though. I think it is. Any comments?

-whitesaint
 

Murderer909

Violent Member
avi2mov and getmp3 should not be in qt library...


those two are tools that you can use in the terminal...what you do is drag EITHER one in the terminal, then you movie, then type desired location and name of the new file to be created "xxxx.mov or xxxx.mp3"

the .mov file should play fine and hopefully it does cause cause it takes longer for getmp3 to make the mp3. okay so if it doesnt work you need to do the getmp3 thing...this will take a little bit so hang in there...when it is finally done, open in it qt pro, extract the sound track....open your original.avi and do a "scale paste" of the sound track over the video and disable the original sound track...this should work well....

hopefully apple will fix the avi audio problems so these steps wont be so necessary.

also, one last correction, you cant watch all .avi's in QT OS X...yes for divx, but normal .avi's dont work....

hope it all works well for you....
 

whitesaint

cocoa love
okay thanks, honestly that did help alot. Okay so when i drag the "avi2mov" file in the terminal, what should i type? or should i then drag the movie file in and then type somthing in the terminal. Sorry im not the best of Unix people. If you could be so kindly to give me an example of what to type or a simple process for a stupid person i would be very greatful thanks :). Oh yeah and I know that it only plays DivX files. Thats all i want it to play :p

-whitesaint
 

Murderer909

Violent Member
drag avi2mov, then drag the orinaldivxmovie.avi, the type the directory and filename of the xxxx.mov as you would like it saved as....if you dont type the directory, the terminal will save the new file in the home folder with whatever name you have typed for it....


same with getmp3...
 

dani++

usin UNIX since '92
Weren't those command-line apps? I thought you had to put them somewhere on your path (/usr/local/bin for example) and then invoke them on a shell session.

dani++
 

jove

Member
Hello,

I have tried both seperately OpenDivX.component and ffmpeg.component in /Library/Quicktime, restarted each time, but cannot veiw AVIs. QT says I am missing a component!

Priveledges are set owner read/write and others read only. What am I missing?
 

whitesaint

cocoa love
Jove, do what Murderer909 said for me to do. It worked great. The reason it isn't working is maybe because you didnt convert the avi's to mov's yet. Or they are not DivX files.

-whitesainnt
 
Top