Beige g3 has probs with MOSX and Classic


My beige g3/300 has 320 MB RAM, the internal CD-ROM and ZIP and two harddrives (one 10 GB, one 20 GB). When I received the package, first I did a clean install of 9.1 and put all necessary folders, extensions an other needed stuff back to the new systemfolder.

My 9.1 resided on the first 4GB-partition of the 20 GB HD. When I tried to install MOSX with UFS, the installer always freezed at the point of changing the filesystem. Rebooting and continue installing (without formatting again) installs everything, but after the final reboot the mac freezes (no progress, even no busy-pointer). So it's impossible to install MOSX on my g3 using UFS in one way with no manual reset.

I figured out, that installing MOSX on the other harddrive using UFS results in a bootable system, but that drive is so slow, that I don't want to use it all day.

BTW there's no problem installing MOSX with HFS+, just UFS makes the trouble. The last installation I did was on the first 4 GB large partition (remember: on beige g3s MOSX has to be installed within the lower 8 Gig of a drive), after I have pulled the whole content of my 9.1 to the formerly (and meanwhile initialized) 2nd 4 GB-partition. Although a reset was necessary, the result was a bootable MOSX.

With the public beta, none of that problems occured, so I'm wondering, why UFS is the cause of trouble now.

The problem I haven't solved yet: When I try to run Classic (using the 9.1 of the other partition), an error-box occurs just after showing the smiling mac, saying "the system used is not compatible with the computer, please install the suitable system software for that computer" (sorry but I'm German and I'm not able to translate it correctly on the fly). That's the same dialog on could see, if one inserted the PPC-Bootdisc of System 7.x in a 68K Mac.

I had another system-folder with an upgraded System (from 9.0.4 to 9.1) and letting Classic use this folder has the same result: No Classic possible, because the system is supposed to be incompatible with the computer).

At that point, I have no idea how to continue. I haven't tried to run Classic unter MOSX installed on a HFS+-volume, probably that's the solution. Any suggestions?
I found the solution how to run Classic with MOSX on the beige G3: One MUST NOT install MOSX on an UFS volume, with HFS+ it works fine. To use HFS+ as filesystem seems to be more than a recommendation...