Blinking Question Mark @ startup

type11

Registered
I turned on my G4/400 this morning to find a blinking question mark at startup.

I'm running 10.1, which was installed as an update to the existing 10.04 on the system.

I'm only able to boot with a 9.1 install CD and upon inspecting the drive I can't really find anything obvious about why the machine won't boot. The 9.2 system folder in the root is "blessed" yet still won't startup the machine.

Any suggestions???

I'm willing to fully re-install 10.1 but would like to try any other options before I go through the process.

In re-tracing my steps to find out why this might have happened, I can think of only a couple of things...

I went into terminal to fix Web Sharing w/ Apache with the following command:

sudo perl -i.prefix -p -e 's/apple_hfs_module/hfs_apple_module/g' /etc/httpd/httpd.conf

And, at the last shutdown I didn't logout as usual - I just went straight to shutdown menu.

Any comments would be appreciated. More than anything, I would like to gain an understanding of WHY this would happen so I can prevent it in the future.
 

SevenK

Registered
I had problems like that running 10.0.4, checking the OSX partion with NU6 resulted in some major errors within the cataloque and some files. After reparing them I never had a problem since. I would give NU6 a try before reinstalling the whole thing.
 

twister

Howdy
i've gotten that when it forgot what system folder i was starting up off of. (ok so it didnt forget but got confused whith all i was doing). So if your in 9 just go in to the startup disk folder and re choose X

See if that works

Twister
 

iKevin

Registered
I noticed this 2 times the other day during reboots.....Luckily it booted though. When I would reboot there would be a quick folder/question mark flash(even though I had changed nothing), then it would disappear and I get the happy Mac and everything boots fine. There has to be some slight glitch since others are having it.
 

twister

Howdy
I'm telling you its confused on which folder to start up with. Re choose it in the startup control pannel.

Twister
 

type11

Registered
Now it works! - thanks Twister

I had to re-boot with the original OS 9.04 install CD, go into the OS 9.2 system folder/ Control Panels/ Startup Disk and select OSX as the startup.

I first tried using the Startup Disk control panel on the CD I booted from, but this version was too old and wouldn't recoginze the OSX system.

I'm curious what causes the OSX to "forget" which system to start from. When I originally tried booting into the 9.2 system I would get an "Unimplemented Trap" error...
 
Top