Bootable zip disk no longer bootable!


I have a powerbook 5300cs that i use zip disks with and i just got a zip drive for my imac. 2 things happened. I reinstalled my powerbook OS 7.5.2 and downloaded iomega tools 2.xx. The other thing i did was share files between the imac and powerbook. The imac runs OS 9.2.2 and uses the iomega driver included in the install. Ever since these events, i cannot boot off of known, good, bootable Zip disks on my powerbook 5300cs. Please Help!
The zip disk has to have the exact copy of the system folder as on the machine.

Are you trying to start up with the zip disk while the powerbook is still connected to the iMac? Dismount the connection, then give it a try.
I dont have the computers networked in such a way. I tried making a new zip disk and copied the entire system folder over. Still wouldnt boot. Perhaps its the driver. Maybe the 2.xx doesnt support booting, or it loads after the system is booted.
Does the zip disk - with the OS on it show up in Startup Disk Control Panel?
Yea it shows up and i can select it too. When i reboot, i see the activity LED flash on the zip drive for a short time, and before Mac OS 7 loads, it shows a floppy disk image as if its looking for a floppy (at this time no activity is occuring on the zip disk). I just tried using iomega 4.2 driver extenson as well as the iomega driver that came with os 9.2.1(the one from my imac). Both did not work. I think this eliminates file sharing with my imac as being the problem.
Have you tried starting up - zip disk inserted, restart, and hold down the Command (Apple Key) + Option +Shift + Delete (backspace key above the return key)?
after days of searching i ended up finding the answer. I needed iomega 4.2 driver and zips formatted with that driver to boot.