Broken folder


I have installed on my cube OS X since 20 days ago, rarely i have worked with them, and most of the days i have used 9.0.4. Today I want to use OS X so I switched the OS with system disk and restart my mac, after that all i can see is a broken folder, if i want to reinstall again the OS the HD is dimmed so it is impossible to reinstall. If i push option key it only display the OSX and the CD OSX but not the OS 9.0.4, i also have tried to restart with the cube reinstall cd but no way the finder displays error 26 after OS 9 logo, any ideas??? I have read here for broken folders but nothing compares to me, in apple support nothing says about this problem

I think you have a broken 9.0.4 system folder in your Cube,
it's really a problem in your "new world machine". Try to zap your pram and them press "c" with a System disk.
I also think that you can select the MacOS CD in the System preferences/ startupdisk.
I'm sorry but I don't speak English normally.
Boot from a CD, find your System Folder for OS 9, open it, find the "System" suitcase inside the system folder, open that, close it again, close the system folder, then go to the startup disk control panel and select your OS 9 HD.

This process is known as "re-blessing" the System Folder.

I solved the same problem on my PowerMac 8600 with to zap the pram (hold down command+alt+p+r while restarting.
You can also try to open the System Disc control panel fron OS 9, select OS X, reboot (a broken folder appears), hold down command+control+start button (restart) and then hold down alt when it starts (boot OS 9, then open System Disc again, select OSX, and restart. That should work, but you have to do this every time you want to change from OS 9 to OS X (I have to do it).