Broken TextEdit


Howdy all.

Seems my TextEdit is seriously broke. I tried to give it a custom icon (don't ask), and not only did it not take, but now if I try to launch it, it 'unexpectedly' quits after a bounce or two.

I have tried:

logging out and in again


running Disk Utility

trashing in users/library/preferences

Even running the X.1 installer again did no good.

However, when I tried logging in as root, TextEdit ran perfectly. So my guess is there is some file associated with my everyday login that is corrupted . . . but other than (which I've already deleted), I couldn't imagine what or where it could be.

While as root, I looked in root's home/library/preferences to see if there wasn't a TextEdit.plist that I could simply copy to my own preferences, but oddly, I couldn't find any such file, even after launching and quitting TextEdit repeatedly. Eventually I figured out that I had to create and save a document before a plist was created.

So, having created a in root's preferences, I moved it to my everyday user's Library/Preferences and changed its ownership to my everyday user. Then logged in as my everyday user . . . and TextEdit still quits after a bounce.

So I'm stumped! Any advice would be greatly appreciated.