Brother Hl 1440/mac Os 9.2.2


I can't print; the alarm light comes on and clicking on the icon gives me a message "Printable spool cannot be found." This morning, after the computer had been off (but not the printer) it began printing, about 10 pages, and then the alarm light went on again. What to do? I just had the printer re-installed yesterday and it worked for 25 pages and then the alarm went on and it wouldn't print.

Do you have desktop printing turned on? That is - is there a printer icon on your desktop?
Turn off Desktop printing. The easiest way to do this:
go to System Folder>Extensions.
Select in the View menu 'By list' to put everything in alpha order
Locate the Desktop printing files (2 of them - Desktop Spooler & Desktop PrintMonitor)
Drag them to the desktop.
Now Close the Extension folder.
Drag those two files to Extensions (disabled) folder.

Restart the computer and immediately hold down the option key and the Apple key.
Continue to hold down those keys until you get a dialog box asking if you wish to do a desktop rebuild. That will appear after the extension icons load at the bottom of the screen.
Release the keys and click on Okay.

Now you will see the printer icon on the desktop with an X on it. Just drag that to the trash.
Next - go to the Chooser and select the printer and port.

You should be printing now.

p.s. sorry for the delay in answering you. I am playing catch up since a major power outage. :(
Thanks for the tip. It worked for 10 pages on so and then the printer went on the fritz again. The message is MSODock Bottom - when I try to cancel printing, it will not. I closed out and restarted, rebuilt the desk top, but to no avail. Any other ideas? I do thank you for your kind assistance. :eek:
No, the toner is not low. The printer is no more than six-eight months old. It worked fine until a month ago, except I noticed a month ago that the alarm light was always on, before I printed, so I'd have to push the button on the printer and then it would print. I have nothing nice to say about Brother equipment. I've had two of their faxes and they were pieces of junk - this may be the same problem. Although someone I respect who knows lots about MACs suggested it.
I searched for the error and couldn't find anything.

A couple things to try;

Set the Extensions to Base and include the printers extensions and restart and try.

Delete the printer and reinstall it's software.

If it gives you a choice for Laserwriter or Postscript when installing, choose Postscript.

I have the Brother 1670N, using it when I first bought it in OS 9, and since, OS X, have never had a problem with it.