Browsing Stalls


I have Earthlink dial-up from home (Verizon/MA). About 9-10 days ago, I began having problems browsing. Web pages only load partway, then stall. Message in the activity window will read s/thing like" "0 bytes of ?" Appears to be image files, not text.

Here's what I've done so far.
1) Updated virus definitions via LiveUpdate; ran Norton. No hits.
2) Tried connecting w/a second iBook; same problem.
2) Emptied cache; deleted all cookies. No change.
3) Set Preferences to load no images. No change.
4) Tried connecting at a different location/phone line. Same problem.
5) Downloaded Camino. Same problem downloading.
6) Earthlink support gave me two alternate DNS numbers. No change. Basically told me they couldn't help.

Right now I'm at an Internet cafe using Comcast and it works perfectly.

I've come to the end of my ideas. Can you help? I'm not a techie, but I can follow written instructions. I've been thinking of switching to Verizon DSL, but will that get rid of the problem, or simply make it more expensive?

I'm runing OSX 10.3.3; Safari 1.2.2

Thx! Patricia