C&C Generals: Sudden loss of good gameplay


It seems like this question is mostly game oriented so I figured this was the right forum for it.

Anyway, I purchased C&C Generals with my Mac about a year ago. (iMac G4, 1Ghz, 256MB RAM) It was fun but I had to keep the graphics down for a good framerate. Then the glorious day of RAM upgrade came to pass. I purchased a 512MB RAM chip and installed it myself. Awesome! I could now play Generals on almost full quality. It was beautiful.

As I got bored with the game, I started altering the game files and such and making my own mods. Well this worked out pretty much problem free until one day... the game framerate was really slow. I don't know what happened but even when I put the quality as low as it goes, it was still pretty bad. I figured that a fresh new install of the whole game would fix it. I trashed the old one and reinstalled. Same problem. I've tried trashing the preferences but still, bad framerate. It runs worse than before I bought the new RAM (I think, don't really remember.) What happened? I've checked that the computer still recognizes the RAM and it does. 768MB DDR SDRAM–it's all there. So does anyone know what's up? None of my other games seem to be suffering from this problem but none of them seem to be quite as processor intensive. I'm pretty sure that the problem lies with the RAM and not the game (obviously.)

Thanks in advace for any help.
Have you updated OS X before the problem occoured? If so, do you have the latest patches for (I persume) OS X 10.4.x?
Might be a shot in the dark, but there may be a file or two elsewhere in the system that could be messing things up, one that you didn't delete? If the RAM is still recognized AND other games work fine, I don't think it is a hardware problem. See if the C&C disc has an uninstaller that will remove the associated files you may have missed. Just a thought...