Cannot Access Internet, HELP!!!

RHITMacMan

Registered
Okay I am having a problem accessing the internet. I actually did the worst thing possible according to some people. I needed to reformat my hard drive and instead of reinstalling MacOS X, I copied my whole MacOS X drive to another drive and then copied it back after reformatting. After doing so I could not startup due to an Adaptec driver problem which was installed with the 10.1 update. So I reapplied the 10.1 update and all was fine except for internet access. I could not get on the internet via Internet Explorer, Netscape, Mail.app, or via ftp or telnet terminal sessions.
The funny thing is, I can ping other computers on my local network and outside on the internet. Apache Webserving also works. I can see my site from other computers, and I can ssh and ftp into my MacOS X machine. I just cannot access the internet via any net application, including the OS X updates preference panel.
I would like to know if anyone else has came across this problem and been able to fix it. Otherwise, any information on things I might check would be greatly appreciated. I have checked all of my network settings and they are all set as before when things were working.
 

RHITMacMan

Registered
Well, actually you pose a good question. I used my laptop computer which can access the internet. Although, I could have rebooted in MacOS 9 and made the posting. Internet will work if I reboot in MacOS 9, just not in MacOS X as of right now. I am also having a funny problem with time. When I reboot with MacOS X, my time seems to keep getting reset to like December something of 1969. Although, if I reboot from MacOS 9 into OS X the time is fine. Hopefully, we can solve this one soon, I would really like my internet back.
 

Jadey

sosumi
How were you able to ping? Network Utility? Can you ping also from the terminal? Type: ping hostname.com
 

RHITMacMan

Registered
Yes, I used the ping command via the terminal and it worked fine for both computers on my local network / intranet and others outside on the internet.
 

RHITMacMan

Registered
When pinging I do usually ping an xxx.xxx.xxx.xxx address and things work fine. My network settings are the same as they always have been. I use DHCP and my network address is supplied by the server. It is the same address that has always been supplied to me. It is also the same address that is supplied to me when I reboot into MacOS 9 and the internet works fine. It's like I may be missing some files or something perhaps. Any ideas along those lines perhaps, files to make sure I have installed that would affect internet communication protocals. Or any other ideas, I'm really at a dead end.
 

RHITMacMan

Registered
I got the DNS from my provider which is not required for my system to work, but I put it in anyway. Nothing changed, still no net access. No one but myself has ever configured the TCP/IP settings for DHCP, so I know what they are supposed to be and they are no different than before the backup and restore. Except for the fact that I now have the optional DNS address in there which I never have needed anyway.

I tried pinging addresses like www.xxxx.com and it would not ping them. Only IP addresses. This lead me finally try inputing IP address into internet explorer, and low and behold it could call up webpages when I explicitly gave it an IP address. This should not be the case though, especially since I know have the DNS address in my settings. I believe something else must be wrong with my system involved with the software. I still want to say that perhaps some file was mistakingly not copied back or not copied back properly during the restore. I'm just not sure what file(s) I should be checking.
 

Appleicious

Registered
I'm having the exact same problem.

I'm on a 56k and my problem started today. I know it is a DNS thing because ping (or any other app) won't work with a domain name, but only IP addresses.

I'm searching the web frantically for an answer. That's how I found this forum. And if I find a solution, I'll make sure to post it.

It should be interesting surfing the web with IPs. ;)
 

Appleicious

Registered
I just wanted to point out that I didn't do the whole drive swapping thing. As a matter of fact, I didn't do /anything/ different from an ordinary day. And why OS X decided not to resolve domain names today is beyond me.
 

Appleicious

Registered
First of all, thank you, GadgetLover, for your concern. I know that your post wasn't directed at me, but I just wanted to make that point clear. :)

Second, I found the solution for this problem and am using OS X to make this post. (Horray!)

Surprisingly, I couldn't find the solution anywhere I looked on the web, but here it is:

The problem that affected me and RHITMacMan is that a file (or two) was corrupted somewhere in the system. I didn't do anything whacky to my system, but these things do happen. Here is the steps to solve the problem:

1. Go into the Network preferences panel.
2. Click on the Location pop-up and change it to New Location...
3. Now that you have a new location set, all of your network preferences have been newly created and any corrupted ones are left in the old location.
4. Change the settings for the new location to mirror the ones you had before.
5. Happy surfing!

You don't even need DNS servers for it to work, but it will help.
 

RHITMacMan

Registered
I actually figured that no one would ever figure this one out so I gave up looking for a solution. I just checked back here today and found that Appleicious had posted a solution that worked for him. I was so excited and immediately tried his solution in hopes that I would not need to totally remove my system and reinstall it from scratch. Unfortunately, this solution did not work for me. I have been resorting to using my laptop much more often or just using IPs on my Power Mac. Still taking possible solutions until I finally break down and make time to reinstall everything from scratch. I have looked into things and found that the "lookupd" and "DNSAgent" as well as several other system components are involved in looking up DNS stuff. So perhaps one of those has become corrupt, I just don't know.
 
Top