Cannot boot except with option key


I interrupted the install because it could not see my external SCSI disk. I got out and had to restart with the option key held down. I initialized the disk and did the install. When I restarted, I got a blank screen. When I hold the option key down, I get OS9. OSX is no where to be seen.
Now I cannot boot at all unless I hold the option key. I selected my startup disk again but that did no good. What has OSX broken here?
I have a G3 all-in-one with 288 meg. The external disk is running off an Adaptec board with Apple firmware I just got from MacGurus. I installed on a Unix formated disk. There is no folder with any mention of OS X on my Macintosh HD anywhere.
Basically, right now I'd just like to boot normally. Then I can try the install again.
Well, the second time I installed, the restart put me back into OS 8.1 (the OS that was on the box when I bought it). I had to do the rebless rigamarole to fix that. (How can anybody complain about command lines when the alternative is GUI wierdness like that?)
I tried installing into a Mac OS extended file system instead of a UNIX one, and that failed also. I try selecting the OS X partition in the System Disk utility, but it never works.
So, I figure my machine is partially trashed because I still cannot boot at all unless I hold down the option key, so I decide to install into the Macintosh HD.
It won't do that without reformatting it. It will not give me the option of installing where 9.0.4 is now without erasing it.
Do I have some kind of file system mish mash here? This system had 8.1 on it when I got it, and I installed 9 on top of that. Did the file system get updated and now Apple in their obtuse magnificence just assumes that if you're running 9 you must be using the new disk format?
My config: G3 All-in-one, 288 meg. The external drive I am trying to get OS X on is connected to an Adaptec 2940U2B, which is an Apple OEM part and has the latest Apple firmware, 1.2, running on it. I really wanted to install OS X any way I could to see if maybe the board is just incompatible, but I can't do that, apparently, without reinstalling everything from scratch. Anybody know if I'm right that the file system used by 8.1 will not support OS X even if 9.0.4 is running on it?
Well after digging around on the Apple web site I found readme about the install process. Probably had it on the CD and it's not easy to find on the Apple site. But it does say that the Mac Standard disk format is not supported under OS X and that's what was on my ATA drive.
Then I remembered another post here where somebody moved their system folder to another drive and it still worked. So I moved everything to my other drive, reinitialized the ATA as Extended, and damn if it didn't install! I moved everything around again to optimize my disk usage and reinstalled again. Now I actually have the thing working.