cannot connect to nt4.0 server


setup: powerbook pismo, 128MB, OS9.04, OS X PB

I haven't been able to access servers in our local network no matter what I tried.

I am connected to two Windows NT4.0 servers. One runs Lotus Notes and I have no problem logging in with Notes under Classic. Internet access over the network as well remotely (PPP) is fully functional too. But I don't see any Neigbourhoods or Servers when I run "connect to server". Turning on AppleTalk didn't help. And the TCP/IP seetings must be OK, otherwise internet access which is routed over a DSL-router and notes access wouldn't work, right?

I don't even see other Macs that are connected to the network with file sharing on.

And in classic I cannot connect to the server either. I see it when I run the chooser, but when I connect to the server, I get a weird message like "Cannot connect to name ;".

If the computer is booted under OS9, everything works just fine.

Any suggestions?
i have the same problem. the volumes on the nt4 server does not appear on my macosx network enviroment.
I'm still searching for a definitive answer, but it appears that AFP (Appletalk Filing Protocol) only works over TCP/IP, not over Appletalk, and NT 4.0 runs AFP over Appletalk only, not over IP. Apparently Windows 2000 server runs AFP over IP (I am not running it so I don't know for sure), so it should work as a file server for OSX beta.
jcooper is correct. Windows 2000 supports AFP over IP, and Win2000 servers that have benn configured to run AFP, and have Mac Shares set up are accessible in OS X. However, they do not automoatically appear as available Network Volumes in the Connect To Server window.

To access a Win2000 share, go to the Connect to Server window, (Command-K), and type a URL that calls on the Apple File Protocol (AFP) as follows:


where is the IP address of the Win200 server. A dialog will open showing you the accessible volumes.
I am having the same problem. I can not see our NT servers or ASIP servers using OS X. I can still see all my servers going through Classic. I can ping the servers and get mail through OS X but when I go connect to servers nothing shows up. I also can't get my LDAP server to work through OS X but it's still fine in Classic.I have found no documentation and the network preference is straight forward but I must be missing something.
Thanks for the insightful replies I have received so far. I have since come across a real solution for nt4.0. As pointed out before, the problem is that nt4.0 does not support afp over tcpip as required by macosx. As pointed out as well win2000 is capable of that. But so is MacServerIP which can be installed and run under nt4.0. I have tried it and it works fine. Only problem is that you have to buy MacServerIP (although there is a free fully functional trial version - well at least for two weeks).

And it's enough to type the server address in the panel. No need to add "afp://". But you really don't see the servers in the network neighborhood.