Cannot find start up disk


After having problems crashing with a USB hub (see another thread) this morning my Mac froze again but this time big time. By attempting to restart I got the flashing question mark interchanging with a small Mac-man folder.
Over the last 2 hours I have:
Tried to reboot holding C down with the Max OS X CD (could not re-install as the version on my Mac is newer than the CD and older versions cannot rewrite newer ones).
Tried to reboot holding C down with the Max OS 9 CD (cannot find a start up disk to install the software on)
Run Apple Harddisk Repair CD and everything was OK.
Zapped my PRAM (apple+option+P+R). The Mac chimed 4 times, I let go and then I got the flashing question mark / folder again.
Tried to reboot from the Software Reinstall CD (1 from 5) but got nowhere.
Somewhere during all this once I got a flashing globe in a box that would not go away.
Tried to get into fsck but by holding down apple+S on rebooting I got the flashing question mark / folder.
I have NOT got a sad Mac icon --- yet.
Current status (at last try, Mac is off right now) was the flashing folder ?? combo.

Who has any new ideas??? I would like to save some files before rewriting the whole system but that isn't even an option right now as none of the CDs can find my start up disk.

Aargh!!! Please help. Mucho thanks, PK
I don't have a suggestion for you on how to fix the current drive, but if you decide to replace the hard drive with a new one, you could then hook the second drive up via firewire or as a 2nd drive in the system and still attempt to get your information off the drive. Just don't overwrite the hard drive without considering this option.
I've got a similar kind of problem...

I was doing a routine Software Update but it crashed and now my IMAC G5 is chasing its own tail during startup. I had to force quit the update after it crashed midway through, it didn't respond, so I restarted the computer by holding the button down but now it never gets beyond the spinning wheel icon on the gray screen to launch Tiger.

I tried holding OPTION on reboot and starting that way to run the Disk Utility but that didn't help. Is there any other forced lauches that people might recommend, or should I just reinstall the system software???

I did restart holding T and hooked it up to my IBOOK and did access the drive but that hasn't helped with my startup problem... any thoughts?
You may want to press the "option" key instead of "C". That seems to me to have a higher success rate. The other option is to press "Shift" + boot which is safe boot mode (performs disk repair). When you accessed the hard drive from the other computer did you do a repair disk or repair permissions? It sounds like some of your system software is corrupt / has bad permissions