cannot install os x because it cannot find os 9.1


Hi All,

Any help would be very appreciated. I have been trying to install Mac os X to my ibook SE 466, 320 MB, 20GB, basically the top model. I bougth Mac OS X installation box which mac os 9.1 is included. I did install this 9.1 onto my ibook. Finished up every needed installation/setup.

Now I try to install mac os x over my ibook on the same hard disk, when the setup is trying to locate os 9.1 volume is said my ibook doesn't have 9.1 installed, cannot find os 9.1 volume. The weird thing is the setup only see my dvd drive.

I did update the start up disk file to 9.2, did everything that could be a problem. I did also update firmware of my ibook. Still the bloody os x is not going to install. Please Please could somebody help me :-(

Please don't be hesitated to write me email at I would love to read and fix this bloody problem. Thanks... Macoby


Simply Daemonic
YOu dont need OS 9.1 to install OS X.
As a matter of fact I have 9.0.4 running and I installed OS X.
Just install it with classic disabled, and then if you want classic
make a folder called old system or something similar and put in
all the OS 9.1 base components in it.




Thanks for your reply, however i have to admit that I am very new to macintosh kinda thing so what you replied to my post is not really helpful to me, but I am very appreciated.

You were saying about installing OS X by disable classic mode, I am wondering if you could elaborate that a bit since I have no idea how to select installer to disable that.

Maybe the problem is this; I checked my Hard drive ID and it said ATA 1 meanwhile my DVD rom is ATA 0. Do you think is there anything wrong with this? Because everytime I use disk utility it can only see my DVD rom not hard drive. I think this is maybe why I cannot install OS X.

Please let me know what you think.



Simply Daemonic
It cannot see your hard drive ???
That is weird! I had the same problem when I tried to install some other thing on OS X.
What I did was this,
I already had 2 partitions, so I formated on (HFS + ) and installed OS X on it. It told me that it would install without classic because I did not have OS 9.1 (I cant remember exactly what it said because I did it a while ago).

Once OS X was installed I went to a machine that had OS 9.1 and went into the control panels, into the Extensions manager control panel, and selected OS 9.1 Base only (the set) and rebooted. Then I made a copy of that system folder which had teh followin inside:

Appearance <folder>
Apple menu items <folder>
Application Support <folder>
ColorSync Profiles <folder>
Extensions <folder>
Extensions disabled < should be an empty folder>
Control panels <folder>
Control panels disabled <shuold be an empty folder>
Contextual menu items <folder>
Control stip modules <folder>
Favorites <folder>
Finder <file>
Fonts <folder>
help <folder>
internet plug ins <folder>
internet search sites <folder>
language & region support <folder>
Login <file>
notepad file <file>
panels <file>
preferances <folder>
scrapbook file <file>
Scripting additions <folder>
startup items <folder>
shut down items <folder>
System <file>
System resources <file>
Text encodins <folder>
classic <file>
classic support <file>
Classic support UI <file>

I think those are what you need in a system folder to make it a 9.1 folder. And you can use this for classic.

If this helped you ok :) If not just tell me again which part you need and I can help out :) (maybe try to reinstall OS X :) )

--> Trying is half the task <--



Thanks for your quick response, that would definitely give me some idea on how to install OS X. However, I did try to use drive setup to make partitions and also did formated it for os 9.1 and OS X. The strange thing is that I cannot see another partition anywhere but my hard drive for OS 9.1 gets smaller. Do you have any idea where and how to set to see that partition?

Then again once installer started up it didn't recognize any hard drive, any partition except my DVD rom. Is this maybe because my DVD rom was set to ID 0? While my hard drive set to ID 1. I am not sure if you know what I am talking about, but you can see this id number when you click on get info from your hard drive.

Well, I really don't know how to explain to you what is really a problem because I don't really know what is the problem. I will file your suggestion earlier about how to set up the 9.1 sys folder.

Thanks a million,


i think i am experiencing the same problem that you mentioned, with the OS X installer not seeing your internal hard drive. i'm trying to install X on my powerbook g3 233 (160Mb/6Gb) and the only volume that shows up in the "select a destination" window of the installer is the install cd. i think i have tried reformating the hard drive with about every format and partion scheme, with 9.1 installed and with out.
if you found a fix for your problem i would appreciate it if you could let me know. i'm guessing the problems are some what related.



Hi Narleth,

As I have been running through all my ibook configurations I have found something which I believe it is the problem and that is relate to your hard disk setting.

My ibook's hard drive is set as a secondary slave which is why Mac OS X install CD cannot detect and select my hard drive to install, and it cannot see Mac OS 9.1. I have brought up this to one of members here and he had the same problem, he did now change his HD to Master and everything is now okay.

What you can do first is to check whether you HD is set to Master or Slave, if it is slave then what I mentioned above"might" be your problem as well. The solution is that you gotta change your HD to master and try to install it again, and you need to upgrade your OS to 9.1.

I haven't tried to fix my ibook yet due to time constrain I have been having at work :) I would appreciate if you would have done so and you can let me k now.




well... i got os X up and running. i ended up replacing the internal 4gb hard drive for the original 2 gb drive that came with my powerbook. for what ever reason, it worked. the 4 gb drive functioned just fine with 9.1 on it, but for what ever reason, it just didn't want to be upgraded to X. beats me!
by the way, on the 4 gb hard drive, i tried the installation with many different partion schemes and formats... nothing worked. on the current 2gb hard drive it worked with 1 partion.


Hi All,

I don't have any partitions on my hard drive, but I have tired to partition it to 2. One for OS 9.1 and one for OS X. The installer didn't see my hard disk where I prepared for it, even the one with OS 9.1 installed.

Nick: Glad to hear that finally you have mac OS x up and running. If you can, can you check property of your new hard disk whether it is on BUS 1 or 2.

Thanks all


i'm not exactly sure how to determine what bus my HD is on.. under Drive Setup, it tells me that my Connection Bus is ATA. not sure if i'm looking in the right place though. i do know that the drive is set to Master (no jumpers or anything). my guess is that the first drive i tried to use was just junk!

let me know if there is an easy way to check which bus my hard drive is on and i'll check it for you.


Simply Daemonic
The place to look for it is in drive setup. It usually is set to ID 1.

As for macboy,
if you can, parition your harddrive (makes you sure back up *all important sata* because the partition will erase everything). Parition it in 2 with the tool (I think drive setup) that came with MacOS 9 (or your system CD that came with your system). Have both partitions be HFS+

Then install macOS 9.1 (or 9.0 or 9.0.4) on your one partition, and install OS X on the other. If OS X tells you no 9.1 is found, just install OS X anyway and do what I told you above for classic support :)