Can't boot at all... not from cd or hd


I have a computer repair company and am completely baffled by this mac.. It is a powermac g4 quicksilver and i dont know what editions of mac os it had on it.. it probably has 9 and then osx installed on top of it.. Those are the cds that i have that were given to me from the owner.. I have tried all of the cds including restore, installs, and the hardware test.. i even borrowed tiger and all of my dad's install cd's for the same exact computer i am trying to fix.. i cant get it to recognize any cd in the drive while holding c.. tried removing the hard drive and installing from cd, nothing.. tried replacing the hard drive with a formatted pc drive and boot from cd, nothing.. tried replacing the cd drive and tried the cds, nothing.. there is nothing that i can do to get it to work.. i am going to sneak over and try my dad's hard drive in this machine, with my luck it is going to mess up his drive.. please tell me what i can do.. im ready to take it to an apple store and ask for help but that costs a bunch.. if i buy a new hard drive it seems as if i still wont be able to boot from a cd.. so i dont know what to do with this guys expensive computer
does it 'bong'? if all your connections are good, then it almost sounds like a hosed mobo or psu. something else to try before pulling out all your hair, maybe the vid card is bad.
What if your machine doesn't "Bong" either? I went out of town, and I've come back to a G4 Quicksilver that won't start up at all - the button glows when you push it, but won't stay on after you let go. ???
When are you holding down the 'c' key? You should start up the computer with the CD in the drive, and immediately hold down the 'c' key when you hear the "bong" startup sound and keep it held down until the computer boots from the CD.

You'll know it's booting from the CD then the "Starting Mac OS X" or "Starting OS 9" screen appears.

Perhaps it's just a case of holding down the key at the wrong time?

What was the problem the owner claimed the computer had?
well, it won't bong if the volume was muted when it was turned off last, or if something is plugged in the headphones slot. if you know both of those are not true, the lack of bong means that the mobo did not 'post'. or in other words, didn't get to run any on board hardware tests. which means the psu isn't putting out the juice it needs, or the cpu died. if you get a chrashing sound, there could be bad ram. being that the light doesn't stay on would make me think that the psu is bad.
i will try to press the c button a little later.. i honestly dont think that is the problem though.. i will try.. the original problem the owner had was that he couldnt get it to boot up anymore.. dont know why or what he did.. do u think if i started switching out components with my dads computer (same exact model) it will cause problems with his computer? for example the hard drive.. if i put his hard drive in this computer and it boots then i know its the drive. but that doesnt explain y i cant get it to boot.. hmmm very strange.. the guy is getting very impatient but i dont think many other people could diagnose the problem right now... i will try pressing c after it bongs
Just experienced a similar problem with a my 4wk old G4 Powerbook (newbie apple user!) - whole system froze whilst running iCal and Angband (a rogue-like ascii based rpg, - could't force quite or restart. Powered down and restarted (multiple times, including with Option key depressed) - will power up but no "bong" and nil display. There was a music CD in the drive which I haven't been able to remove even with depressing trackpad/restart. Battery removed/factory settings reset to no avail. Unit in same condition as when pulled from the box - no mods. Apple is still really unfamiliar territoty for me, am I missing something?