Can't Boot, Help!


Dear Friend,
As usual my bad luck with computers continues. My cube refuses to boot in OS X anymore. It gets stuck in the white and gray start-up screen and gets no further. I have run a variety of diagnostics from CD's. They all say it is fine. It boots from CD's without complaining. It works fine in 9, so I am guessing it is not a hardware problem. There seems to be something wrong with the startup process. I even tried booting in the Unix mode.There I get what appears to be an error message( I think). It says BSD root= blah,blah,14major,10 minor( which i imagine to be errors). It will then not respond to Unix commands. Any ideas?I am thinking reinstalling is the next step. Thank for your help.
Yours truly,
Howdy Walt;
I too am having startup probs with my g4. What did you do to remedy the problem? Do you have keyboard commands during start up?
Yes, I have tried all the Keyboard commands, I think?. I am at the end of my rope and I am thinking of reinstalling the system.