Can't exec anything

kilowatt

mach-o mach-o man
It would appear that I have a similar problem - I'm not seeing any application icons - they all have folder icons. This happened to a computer that perviously had OS 9.1. It was the first time installing X on it, and its really messed up.

First time installing X, X installed, and the computer reboots into this fancy setup program. I went through it all, until I got to the timezone selector. When I pressed the pulldown menu, the setup program sort of disapeared. And I was in a non-functioning aqua interface (nothing would run).

So I tried re-installing os x. X said it needed abour 350 mb of space for an 'upgrade'. Clicking on the "format and erase disk first" option changes the install size to 1.1 gb. Well, I didn't want to erase my copy of os9, so I did the 350 mb option. It installed alot of stuff, rebooted, and just drops me into the same old messed up aqua. (btw, using the '>console' command was interesting - nothing would run except standard unix console programs, and the rastorized text would sometimes appear to run over top of the screen - such as when I typed clear. And then I would have to reboot).

Well, I booted up with my os9.1 cd, and erased my 'Macintosh HD' partition. Mind you, I had backed it up before attempting any os X installs into a folder on another partition. After erasing the partition, I dragged my os9 system folder back into the Macintosh HD partition. Now my somputer was like it was before. Working.

I tried installing os X agian, and with similar success - no working applications. Calculator.app looks like a folder. Apparently, with my new install, I can't even open the folder because I don't have access. Wait a sec... I'm logged in as root, with admin privliges, I thought... oh well.


Well, I'm pretty stumped. I guess I'll call the os X help line on monday. Btw, Booting into os 9 is really hard to do. Holding down opt/alt on startup gets os9 up, but it doesn't have any of my preferences (desktop pattern, etc), and none of my extentions load. And, when I select my 'System Folder' in the startup disk control panel (either the one from my hard disk, or from the one on the os X cd), the finder grabs my attention with a message like "The folder 'System Folder' needs to contain the files 'System' and 'Finder' inorder to startup correctly. Are yopu sure you want to continue?" Well, those files are in that folder. I tried rebuilding the desktop (I was getting desperate) and it didn't change anything.

If yall think it will help, here's my partitioning scheme:
(these numbers are to represent order, not necessarly every partition on the diske - such as apple-patch partitions and such)
1) Macintosh HD - contains os 9.1 and os X (2 gigs)
2) Files - thats where I place my programs and documants (17 gigs)
3) root - thats an apple_uinix_server partition I use for Yellow Dog Linux (17 gigs)
4) swap - Another partition for Yellow Dog Linux (128 megs)

My computer is a rev.A beige power mac G3 266 with 128 megs of ram, and a 40 gig ata hard drive. I've also got an additional network card (which the os X installer seams to know to use when it connects to apple with my name and address), a Rage Orion pci video card (in addition to the on-board video), and a firewire-usb combo card (os X seams to recognize the usb mouse I use).


Anything would be appreciated. Thanks
kilowatt@cinci.rr.com
 
Top