Can't find the cdrom drive


My dual usb ibook doesn't seem to recognize the cdrom drive anymore. When I put a cd in it will spin up, but nothing on the screen. If I put a osx disk in and restart holding the option key, it gives me the option of booting from the HD or the cdrom, but will freeze if I try to boot from the cd. The cdrom is as far as I can tell made for apple, but I am not sure if it is the original. The model number is CR-176-M. I also picked up a sony CRX810E because I read somewhere that they were compatible with ibooks, but I still get the same thing. I am currently running os x 10.1.5, are there any drivers I should try, or is this something more serious?
Are you saying you removed the CR-176-M internal optical drive and installed the CRX810E? If so, it probably isn't the drive unless both are damaged or both of their lenses are dirty. Having said that, try what I've written below.

If you have tried several CLEAN cd's in the drive and they don't read as well as a few clean bootable cd's that you attempted to boot off at startup and none work, then I'd try cleaning the lens of the drive and retest as above.

If, after doing these steps, the drive still won't read cd's, I would normally say you need a new optical drive, but if you've done this with 2 separate optical drives, then you've got a problem that is neither related to the drive nor the cd's so that leaves a software or logic board problem. My guess would be logic board if you have ruled out the OS as the culprit.
Yes, I swapped out the cr-176-m for the crx810e. But not until after I had problems with the cr-176-m. My original problem was it was freezing and startup, with os 9 and I would get an unresolved kernel trap error if I tried to start up in os x 10.1. When I removed the cdrom completely, the ibook boots up and works fine (which is why I thought maybe it was just a bad cdrom drive). With the cdrom removed, I updated to 10.1.5 which allowed me to boot up with the cdrom back in it, but not being able to access the cdrom from osx.