Can't Get Classic to Work In 10.3.9 Using User Account


Hi captmonkey4777,

Got exactly the same problem, together with another one: no more possible to print in OS X (I'm running 10.3.9 on a 17 in. PowerBook G4).

Tried lots and lots of things to solve the problem but nothing helped...

For good reasons, I finally suspected a problem with the /tmp folder. (One year ago I was already in trouble with Software Update because of it.) In fact, the problem is that there is a missing link for that folder. To check it, do the following:
1) Open Terminal
2) Type "su" to log as root
3) Type "cd /" to access the "/" directory
3) Type ls -l to list the contents of the directory
4) The line showing /tmp should look like this :
lrwxr-xr-x 1 root admin 12 25 Mar 12:00 tmp -> /private/tmp
5) If you can't see "-> /private/tmp" at the end of the line, it might be the problem! So...
6) Type "rm /tmp" (to delete the directory)
7) Set a correct link to the true /tmp directory by typing
"ln -s /private/tmp tmp"
8) Quit Terminal

Try to launch Classic... It now should be ok!

Tell me if that worked.