Can't get home dir to automount using ldap and afp

jonduf

Registered
I am trying to set up a server to have a central place for usernames, passwords, and home dirs.

I can get it have a central place for the username and passwords but for some reason they log in always has trouble mounting the home dir.

I set up a share point at /Users on the server. I made it afp sharing and I made a record and I set it to hold the user home dirs

I then go under and user's account in the workgroup app and select the home tab, i choose the option that is there click "create home dir" and then click save.

I log out of my admin user.

the username and password authenticate at the server computer and from a separate client computer, but the home dir never mounts, and therefore doesn't let me log in all the way.

If i don't use a network home dir, everything works fine, but this would pretty much get rid of the whole objective i am trying to accomplish

any help is really appreciated this is for the small business I work at.

I am using mac os x server 10.3
and the clients are running mac os x 10.4

thanks!
 

Art Vanderlay

Registered
How long are the following names?

- Username
- Name of the volume on which the home dirs reside
- Name of the server

When creating the Share Point is important to use fairly short names for both the Volume and the Folder. This is because the total length of the eventual path to the user home folder on the client must be fewer than 89 characters (the path on the client to a home directory is /private/var/Network/Servers/[servername]/Volumes/[volumename]/[sharename]/[username])

See http://docs.info.apple.com/article.html?artnum=107695.

If it is not that, have you definitely enabled AFP in Server Manager on the server
 

dfemorton

Registered
I had exactly the same problem but sorted it by a lot of trial and error.

I could not create home directorys!!!!

you must make sure that AFP is enabled in server admin.

Make sure that AFP is enabled on the users folder and that it can be shared as a home directory.

make sure that you click on "create new home folder" and then click save under the accounts home folder tab in workgroup manager.

I am new to this myself so if there are any more techies that there is an easier resolution then please point us in the right direction!!!
 
Top