Can't get past grey screen + weird cursor corruption

hinotoxin

Registered
a few months ago my Macbook Pro (2.16ghz intel core duo purchased in 2006) froze completely giving the spinning rainbow cursor. The cursor also showed a small rectangular box of faint blue horizontal lines behind it, which moved when the cursor moved.

It would not go away at all, even when other apps or the desktop were clicked on, so i forced shut down. Upon restarting it showed the apple screen, but then just a blank grey screen which it would not go past.

So I forced shut down again, and after this it started up normally and worked as normal up until a few days ago when the same thing happened with the cursor again, and now it will not go past the grey screen at all.

However it DOES boot up ok in safe mode. The hard drive seems to be fine, ran disk utility and just a few permissions needed repairing which I have done.

I took it to the genius bar in my city today, they had a look, couldn't get it to load off their own hard drive. At one point he got it to load onto some other screen... which i'm not sure the name of but it showed a lot of small icons going horizontally across the screen. He said that he was trying to click on one of them and it seemed like the shift key was constantly being held down.... and that the problem might be something to do with that..... but surely then that would mean it would always boot in safe mode? and it doesn't seem to be doing it when actually open in safe mode.

another guy in the place said that due to the cursor issue it could be a problem with the graphics card, and with the old machines, it meant I would need to replace the logic board. neither of them really seemed to know what the problem actually was though and they just gave me the contact details to a place called macsys which is another official place that fixes apple products, for a price of course.

just wondering if anyone had this problem and knows of a fix, as i cannot really afford to replace the logic board at this time. oh also it is running snow leopard, but i do not have the installation disc as it was purchased second hand.

thanks!
 

Cowsaki

Registered
I had a similar experience just yesterday with my old (2002 or so) G4 Dual 1gHz. I was trying to get it to boot so I could give it to someone who needs a mac but having a very similar problem to the one you are describing. It was baffleing me.

You know how all fast graphics cards have a 4 pin power connector? This is so they can draw more current that the mother board is supposed to supply. Through that connector, you tap power off one of the drive connectors. Well for whatever reason, that line had gone dead, or weak, I'm not sure which, but as soon as I removed anoter old unused drive and connected the graphic card power connecter to the unused drive power line, everything started working perfectly again.

A possible reason why this might sneak by the Genius bar: When I put the mac in Target mode by booting with T key held, I was able to read the system disk remotely on another mac via firewire connector. The system drive looked completely fine. Disk repair repored no problems. If the power connector was really dead, this shoudn't have worked.

So I never thought a drive power line could be a problem. But now I think that the graphics card uses more power to do the hirez desktop that it uses in "Target" mode or in "Option" mode or "C" mode which are lowrez. All of those worked right up until the OS was really supposed to load up. I think it detected the lack of power at that power port on the graphics card and so it refused to go further.

If you have a similar power cable to your graphics card, I'd check where its connected and whether power is present or not.
 
Top