Can't get telnet to work.

k0bas

Registered
I can't telnet back to my computer. Not even from same computer. It worked before, but I put in a new hard drive, and reinstalled OS X. I did everything I did with the original install.

Any ideas?

Thanks

Brian
 

avalenz

Registered
Well, not really knowing anything about your setup, the first thing I can think of is to check the Sharing system preference and make sure you have telnet enabled.

-Ali
 

Torch'em

Registered
Maybe OSX is running Telnet in SSH mode, which is port 22 and requires a more advanced telnet client usually.
 

nmcg

Registered
Possibly, you are using a different IP to telnet to than should be used.
You need to try 127.0.0.1 first, not 10.0.0.x
:)
Neil
 

k0bas

Registered
I have sharing turned on, in fact everything is on. I have a static IP. I can ftp to my computer, and the web server is running fine. Don't know what I did to mess this up.

I tried to telnet localhost, telnet (my IP).

Brian

G4 450
384MB Ram
45GB IBM 75GXP
OS X 10.0.3 and sometimes 9.1
Fixed IP on Cable modem

I'm new to Macintosh. I just bought this G4. I was using the other type, best not mentioned here.

I like this better. I really do.
 

blb

`'
If you've updated to at least 10.0.1, the 'Allow remote login' option in the Sharing preference turns on ssh instead of telnet, for security reasons. This means you have two choices, either start using ssh (which offers more than telnet, since it can also securely copy files via scp as well as secure logins) or manually turn on telnet if you absolutely must have it.

To turn it on, you need to open a Terminal window and use a text editor (vi, pico, or whatever) to edit /etc/inetd.conf as the root user (so run the text editor with sudo). Find the line:

#telnet stream tcp nowait root /usr/libexec/tcpd telnetd

and remove the # from the beginning of it. Once saved, run,

kill -1 `cat /var/run/inetd.pid`

to restart inetd, and telnet will be open for incoming connections.
 

k0bas

Registered
blb. Your info was right on target. Telnet is running again.
Thanks for all the replies, everyone was very helpful.

Brian :)
 

avalenz

Registered
As an FYI, you generally want to be running SSH and NOT telnet since SSH is secure (while telnet is not)--especially if you're on a fast connection with a static IP. There are clients for SSH'ing to your computer available for just about every platform, too. My $.02: use SSH.

-Ali
 

k0bas

Registered
I'll keep the SSH in mind, and work with it in the hear future. I just have a goofy reason for telnet right now. Its not something I plan on running more than a few days.

Thanks for the info.

Brian

G4 450
384 MB RAM
45 GB IBM 75GXP
OS X and Sometimes OS 9.1

And now another G4
G4 533 Dual
512 MB RAM
2 X 45 GB IBM 75GXP ( I like these drives)
OS X and Sometimes OS 9.1
:) :D
 
Top