Can't get Windows XP user to log onto Tiger server

drj434343

Registered
I'm using OS X Server 10.4, and trying to get a Windows XP user on our network to logon with his own account. I've created a new user profile in Workgroup manager, but when going to the Windows tab for his settings, it said I needed the password to be "open directory" in order to enable windows logon services. I went to the advanced tab to change the user password type from "shadow", but there were no other options availible to choose from at the time. I did a bit of homework, and discovered I had to activate "open directory" and "windows" services in server administration. I also learned that I needed to change the server role in the "windows" service settings from "standalone server" to "primary Domain Controller" in order to have different password options for my user and to be able to enable windows logon services in the first place. However, whenever I try to change the server role to anything but "standalone", I get a error saying the system couldn't make the server a Windows domain controller.

This seems an overly complicated way to get a Windows user to login, but so far I've only had the server help documentation to guide me, and I'm thoroughly confused. Could anyone give me a hand in getting a Windows user to logon with basic access to shared folders? Thanks.
 

cabbage

Registered
You shouldn't have to do all that but you can.

Are you sure you have Windows/Samba/SMB sharing ON for that share you want them to connect to? That could be your problem.
 

drj434343

Registered
I double checked the sharing properites of all my shared folders, and Windows/SMB/etc is checked. The problem occurs before that, I can't even get any user on my system to have Windows logon privlidges.
 

Go3iverson

Registered
Yeah, you don't need to make the Tiger Server a PDC to accomplish this. Two areas you need to have enabled.

1. In Server Admin, be sure that you have Windows sharing enabled.
2. In WGM, be sure that you have Windows/SMB sharing enabled on the share.

The user your trying to use, this is a user you created in the LDAP on your Tiger Server? This server is an OD Master? Any AD in the background supplying authentication and users?
 

drj434343

Registered
Thanks for the response Go3, I have Windows sharing enabled in SA, and Windows/SMB sharing in WGM for the folder I want to share. The server also is configured as an OD Master currently, but I've had that turned off and on while experimenting with no success either way. I created the user in Tiger, but can't change his password type to anything but Shadow. I'm assuming I need to change the password type to open directory, in order to get him athenticated from a Windows machine, but I'm at a loss as to why I only have one choice for password at this point. Any new thoughts?
 

Kees Buijs

Registered
drj434343 said:
Thanks for the response Go3, I have Windows sharing enabled in SA, and Windows/SMB sharing in WGM for the folder I want to share. The server also is configured as an OD Master currently, but I've had that turned off and on while experimenting with no success either way. I created the user in Tiger, but can't change his password type to anything but Shadow. I'm assuming I need to change the password type to open directory, in order to get him athenticated from a Windows machine, but I'm at a loss as to why I only have one choice for password at this point. Any new thoughts?
This means that Open Directory is OFF. Turn this ON with SERVER ADMIN. Remember the SUPERUSER = DIRADMIN under 10.4. The password = ROOT password.

Also you need to login as DIRADMIN to make changes to the password type.


Kees
 

drj434343

Registered
Thanks for the great info Kees, it worked perfectly, albeit slightly conplicated for what I thought should have been a simple task. Nevertheless, I appreciate your help!
 
Top