Can't index my own hard drive? Please help!


For some reason, even though I installed with one user (me) as the administrator, I don't have privileges to do certain things to my hard drive. The most important ones being 1. Indexing (and searching) my drive, and 2. Deleting things from certain parts of my hard drive.

This is a 10 gig with no partitions, btw. OSX installed over OS 9.1.

What the hell??? How can I force OSX to understand that I AM THE ONLY USER HERE? I'm tired of being told that I don't have permission to do things to my own Mac!!!

I've tried the users panel under system prefs, but that doesn't help.

Please, I beg of you, if you have any ideas throw them my way.

I remember trying 2 things with privs.

1. Set the Mac drive to ignore privs. there are some side effects.

2. More dangerous though is to login as root or su to root.

If you don't know your root password you can set it using a nice cut and paste trick. Try using NetInfo to cut the encrypted version of your password over the root password. It worked in PB anyway.

I still have a problem with certain files created under OS9 apps and then trying to manipulate them in OS9
Just save things under your Documents or home folder - you can index those.

In OSX, whether you think so or not, you aren't the only user. There's nobody, root, www and some others - look in NetInfo.

And you should never have just one user. Always make one or 2 'spare' users with admin priveleges so you can fix things as neccessary.
Thanks all. I'm starting to understand how it works. I've now reinstalled OSX and 9.1 on separate partitions and am reorganizing all of my files so that I can index them.