Can't Index RAID drive in Leopard server

brianleahy

Colonel Panic
I have a Dual G5, running Server 10.5.8. Attached I have a Promise SmartStor DS4600, connected by Firewire 800. The SmartStor is a 4GB raid device, configured as RAID5, capacity 3 TB. Apple sells it from their online store...

I can't get Spotlight to search any of the share points on the RAID, either when logged in at the server itself, or via AFP.

In terminal, I get:

server:~ admin$ sudo mdutil -s /Volumes/SERVER_RAID5
/Volumes/SERVER_RAID5:
Indexing and searching disabled.

...no matter what I do.

I've tried mdutil options s, i on, i off, and E -- to no avail.

I have gone into System Preferences, put the external drive into the "Privacy" list, then taken it off. No good.

Tried turning off the Spotlight Indexing permission for each share, then reenabling -- no good.

Ran Disk Utilty / Repair and DiskWarrior. Didn't help.

Tried the shareware utility "Spotless" - it had a mysterious "unknown error" trying to turn on indexing.

I tried:

sudo chmod -R +ai "user:_spotlight allow read,readattr,list,search,file_inherit,directory_inherit" /Volumes/SERVER_RAID5/eachSharePoint

No luck.

Then I tried connecting the RAID drive directly to another Mac running OS X 10.5.8 client (not server) -- and it indexed the drive with no problem and searched it with ease.

Next I'm considering deleting all my share points and re-creating them - but it seems unlikely to help. Any ideas?
 
Last edited:

Giaguara

Chmod 760
Staff member
Mod
At least previously Spotlight didn't like to index remote drives.
If you get the same when trying to index that same drive remotely from some other system I guess that would still be a valid limitation/feature/howeveryouwanttocallit.
 
Top