can't launch Safari, UnrarX and iTunes



I did a standard weekly on-line software update on OSX (10.4.11), don't remember which one, but it was a small one, java and something else. (so no OS update, just software update).

Result is that i can't launch Safari, UnrarX and iTunes anymore (and who knows, maybe a few other apps that i didn't try since the update).

I tried to reinstall all 3 apps, but i still can't get them launched.

What could be the problem?

Kind regards, thanks in advance,




I have a G4 Power PC 733 MHz 640 Mb SDRam. 10.4.11
The support team moved my question to the forum, that's why it doesn't say what Mac i have (they have all the details).

I tried to install the Combined Update like you said, but during installation 'the installer unexpectedly quit', so i can't install the update.

I guess installer is another app that doesn't work after the update of last week, on top of Safari, iTunes, and UnrarX. It's true that when trying to reinstall UnrarX f.e., the installer also quits unexpectedly.

I really don't know what the problem could be!


Open and read system log while launching applications.
If there are entries that appear while launching copy/paste them into this forum.