Can't launch some OSX apps.

jerome

Registered
I have only been using OSX for under 1 week, but some of my apps have stopped working. They used to launch, but now they will not. The task bar seems to mementarily make room for them, and then returns to its previous state.

However, I have noticed that if I log in as the 'root' user I can launch the apps concerned, 'Music Player, Internet Explorer, iCab'.

Does anyone know why I can launch these when I'm logged in as root, and not when I'm logged in under my name? I'm completely new to OSX and UNIX so any help much appreciated.
 

Tigger

Bring mich zum Licht!
Originally posted by jerome
Does anyone know why I can launch these when I'm logged in as root, and not when I'm logged in under my name? I'm completely new to OSX and UNIX so any help much appreciated.
This should be something about the permissions.
You have to go in the Terminal, and change the permissions via chmod.
Sorry, but I don´t know the exact usage of this command right now. But you could look for yourself with the command man chmod, which shows a man-page for chmod.

Unfortunatly there is no other way to change permissions in public beta, hopefully Apple will integrate some User Interface in the final for changing such things.

But wait, someone at the forums has written some User Interface for chmod, I think. You might want to search for chmod for finding where you can get this...
 

jerome

Registered
Thanks Tig,
I've actually reinstalled now, and solved the problem.
Cheers Anyway.
 
Top