can't logged in as a root

mtint

Registered
Hi,

I was quite excited after installing OS X last night but
to my suprise I can not logging in as a root?

tried su - from the terminal and also via. a GUI - no luck!

Has any one had the same problem:

I have original bondi with 192M of ram, 20G HD.

 

lmobrien

Registered
Had similiar problem, but was able to open Terminal window and set privileges accordingly. You may have to delete your current user and re-add.
 

dmccoy

Registered
I found that booting off the X CD and changing the root password with the "change password" utility worked for me :)
 

grimjim

Registered
Can't you try something in the command line like:

sudo passwd root

Then you can enter a root password and use the root account.
I find that it's generally easier (and probably slightly safer) to log in via telnet as my user account, and then su to root. At least it takes a little effort to do it, so you don't habitually use the root account. I suppose you could also use sudo, but I haven't tried this yet.
 

Teo

Registered
Hi,

have you try to go into the NetInfo manager and then go into 'Domain'->'Security' and 'Enable Root User' ???

it did work fine for me ... you can use 'su' after without any problem ...

hth,

-teo.
 

VGZ

Registered
You can also boot off the install cd and set the root password from there. Look in the menus for reset password and enter a root password.
 

mtint

Registered
Hi,

Booting from the CD and resetting the has worked
for me - so thanks very much for your tip.
 

billbaloney

House pianist
You can always carry out root-level commands with sudo. If you need a root-level shell, as strobe pointed out somewhere else, you can "sudo tcsh" (or whatever other shell).
 
Top